EOS Installer can't see SSD

Hi guys,

I’ve been using EOS exclusively since last year and have put it on many different machines and its worked flawlessly (thank you!)

I recently got an 2019 iMac with an Samsung 970 Evo SSD that I have partitioned so that I can dual boot OSX and EOS. the issue I have at the moment is that the EOS installer just can’t see the SSD at all and I don’t understand why.

Is there some sort of protection that I need to disable? If so, does anyone know how?

I’ve also tried Linux Mint and that can’t see the SSD either.

I’d really appreciate some direction on this.

Thank you.

Sometimes you need to format the space you want to write to Fat32 or some readable partition that has available space. There are a lot of guide out there about running Linux on mac’s. Have you followed any of them?

I don’t think that you can “turn off” anything on a mac like you can on a PC.


Some internal SSD’s are weirdly named by Linux, not like “/dev/sda”. A short time ago I received a laptop with 64GB internal SSD and decided to erase Windows not updated in years. When I went to format it I looked for “/dev/sda” and didn’t find it, it was something like “/dev/mmc0blk”. It could have “nvm” in the device name or something else. Maybe your MacOSX is hogging all the space on the SSD, leaving no room for anything else. Otherwise I don’t know what to tell you since I never had a Macintosh.

Thanks for helping me out with this, I really appreciate it.

I have formatted the SSD to MS-DOS(Fat32) using Disk utility on the Mac and both bootable USBs can’t see it.

Running fdisk -l doesn’t show them either. I’m wondering if the SSD has RAID or similar.

Worst case is I wipe the entire disk and start fresh but the disk needs to be visible for that to work.

Then SSD isn’t an Apple one, it’s a Samsung Evo 970 so shouldn’t be too difficult to get to work eventually.

Thank you for helping me out with this, I’m really greatful.

I ran fdisk -l and I could only see the bootable USB. I will take another look.

I formatted the disk to MS-DOS/Fat32 and it’s still not visible. Sounds silly, but I named it Linux (so I could find it more easily ironically) and I wonder if that’s why. I very much doubt it though.

I have made a tiny bit of progress:

I have booted into Linux from a live ISO and I ran this command:

lspci -nn | grep NVMe

And it shows a Samsung device, so I assume it’s the Samsung SSD. Does anyone know how I can use this information to make it visible to the installer?


Check in bios if drive is set to ahci.

  • avoid using MBR and boot UEFI required GPT partition
  • check if you can juste create GPT partition with osx and see if it can bee see by EOS installer

in mots case in PC all disks should be on AHCI

The machine is a 2019 iMac, I’m not sure it has a bios :cry:

AFAIK the iMac uses Open Firmware.

What ever it has for Firmware settings you should check that the drives are set for ahci.

Thank you for this. I think your right about Open Firmware too.

Unfortunately I can’t access it though as the keyboard shortcut command+option+O+F doesn’t seem to work for me.

I feel like I’m really close to solving this.

I just looked it up and Open Firmware isn’t used anymore hence why the shortcut isn’t working. It might use EFI instead.

It’s probably UEFI firmware so you just need to figure out how to access it.

OpenFirmware is before generation mac intel , it concerns PowerPC architecture , not intel

trouble with Mac intel : if you can boot on USB iso , try to boot on UEFI , not MBR
systems ox are only accepted by boot EFI entrance mac , unless you put grub / systemd inside

you can boot with Alt command and USB iso

if possible check under install , open a terminal

inxi -Fza 
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
sudo efibootmgr -v

Do you still have the mac OS installed on it? If you do then you should try to do the boot camp or whatever to prepare the disk for another OS. Then try to do your installer.

“if you can boot on USB iso , try to boot on UEFI”

How do I do this? As far as I know holding the option key is the only way to boot from a USB.

Output from inxi -Fza:


It just shows the bootable USB and nothing else.

test -d /sys/firmware/efi && echo efi || echo bios
The above just outputs “efi”.

sudo parted -l
Just shows to bootable USB

sudo efibootmgr -v


My iMac doesn’t have a T2 chip but I have also booted from a custom version of EOS built for Mac’s with the chip and still it’s.not showing.

I can’t believe that this is impossible to solve. It must be some how.

I have to admit though I’m running out of options.

It shows unknown usb bridge. Is that an external drive plugged into it?

Some help might be here, but you’d have to dig in…

Also, disabling SIP (Apple’s system integrity protection) might be of some “last resort”, if not willing to kill it all… (usually not recommended).

Yes, it’s probably the bootable USB drive.