EnOS Installer Failed (Partially) 😬

Recently when I tried the EnOS net installer for installing KDE Plasma it failed on me , but only partially . It did install the base packages and I could boot into tty . But all other packages related to KDE Plasma were not installed . But they were downloaded as I did watch the progress of installation in the terminal during install . I could install all plasma packages from the tty once I booted without downloading them . So my question is why did the installer download all packages and didn’t install plasma packages :question::question::question::question::question::question:

:thinking::thinking::thinking::thinking::thinking::thinking::thinking:

Post a link to the ISO used and I will burn a copy and run a plasma install this morning and see what is up.

1 Like

That is why I love this forum! Thank you @BONK

2 Likes

It’s the latest release , I verified it too .
https://mirrors.tuna.tsinghua.edu.cn/endeavouros/iso/endeavouros-2020.09.20-x86_64.iso
This is the source ( I opted for direct download )

I didn’t try out the net installer after that , but will do to see if it happens again :stuck_out_tongue_winking_eye: , just curious

I tried that link. It was really slow and the download actually failed. Downloading from github now.

Me too ( I Think I am Addicted To This FORUM :wink: )

are you the person without username on Telegram?

No I have a name and username , besides I am not in the telegram group :man_shrugging:

And which mirror do you use ?

Germany & singapoore should do fine … india itself not :slight_smile:

The fastest 10 :man_shrugging:

1 Like

I just finished the installation (well and got firefox set up). No issues so far. This is on metal on an old Thinkcentre. I am going to have to go with that mirror being used to download the ISO is having issues. Like I said it failed to complete the download. Github link works as expected.

I checked sha512sum and pgp signature on the website . Well if you think my iso was corrupt we can check the sha512sum of that iso with the one you downloaded now . Here is the sum

fa1911a9b80dc148f80d0f38cf027193f3402abc98277be162b7d8708408abb9de6637e70bccbe91666d2208329fad581f59c9020590686e75a094ea13943541

FA1911A9B80DC148F80D0F38CF027193F3402ABC98277BE162B7D8708408ABB9DE6637E70BCCBE91666D2208329FAD581F59C9020590686E75A094EA13943541

:man_shrugging:

Which packages exactly did not install for you?

when it does from Net installing, it installing things in blocks… there was no 404 seen?

edit: when it goes about network install you have to think ootb, it goes also for information to git if some changes, but then it get the packagelist from git.

then it goes to install over network.

I booted directly into a tty , so the base system must’ve been installed properly . Nothing related to plasma ( sddm and all other stuff ) wasn’t installed . I noted down the packages which I chose in the net installer and installed them all using pacman . Well one package was downloaded . That maybe the reason this happened .

I will try installing again and cut the network connection when downloading packages is almost finished to see if that was the case :grin:[quote=“ringo, post:14, topic:9719”]
there was no 404 seen?
[/quote]

Don’t think so . Maybe it was at last and the installer showed everything is done and I didn’t notice and rebooted :man_shrugging:

mmmm got no idea wat could happing allone somerough idea that can’t be the truth
hard replicate.

install log will be saved onto installed system also, you will find it as /var/log/Calamares.log

1 Like

Yes what @joekamprad says would be very helpful. I am thinking maybe you started by selecting one DE changed your mind went back in the installer and picked another DE and something got tripped. Clamares isn’t always happy about going backwards with the installer.

You can also return the output from endeavouros log tool. Set it up like in this screen shot and post the link:

Screenshot_20201116_142206

4 Likes

cat /var/log/Calamares.log | curl -F 'f:1=<-' ix.io
would do this directly from terminal

2 Likes

Well I switched to Garuda ( 1st i3 then KDE ) after that and came back to Endeavour . So no logs to look at . Maybe next time :grin:

Nope I went straight for Plasma . Maybe network error was the problem . Can that happen ??
If one package was not downloaded then Calamares install base packages ( well the only group available with all its dependencies ) and show the popup install is complete leaving all other packages in the cache :thinking: