Endeavouros-theming update requires manual intervention

The endeavouros-theming update requires manual intervention

Type

sudo pacman -Sy endeavouros-theming --overwrite /etc/pacman.d/hooks/\*
sudo pacman -Syu

Thanks to @dalto for thinking with us.

23 Likes

French translation: La mise à jour de Endeavouros-theming nécessite une intervention manuelle

4 Likes

Salut Fred , c’est quoi le paquet endeavouros-theming?

Celui qui permet d’avoir la charte graphique d’EndeavourOS.

Yes, that did the trick! :slightly_smiling_face:

Thanks,

1 Like

On deepin i did this but there is hooks in the Endeavouros repo that won’t install after doing this?

Screen Capture_select-area_20200711181427

Sorry needs to be done in terminal or tty.

I did the manual intervention but it shows the hooks aren’t installed in pamac. I tried to install them again thinking it would show them installed but it say’s they are already installed obviously and gives that same error.

Edit: No worries I’m going to try something else anyway.

Thanks…it all did the trick :slight_smile:

3 Likes

ComplicatedWildKitten-small

1 Like

Interesting note… I built a bare metal Arch and I got this update! I decided I didn’t want to be without reflector-simple and eos-notifier - so I added in the EndeavourOS repo :grin: - that got me this ‘update’. Interestingly, though, both screenfetch and neofetch ignore it!

1 Like

Another note - as I travel through my different distros, updating as I go…
Apparently, not only do others have the same ideas - they have the same filenames in their update packages! Arcolinux was doing the same thing, and used the same name for the hook files (both of them) - and you can’t fix that as easily. Adding endeavouros-theming to the IgnorePkg in /etc/pacman.conf worked though :grin: The things you find out as you go on these systems…

You need to (re)install or upgrade lsb-release and filesystem packages for the hooks to trigger. That may still happen in the future (?) Adding endeavouros-theming to ignored packages will just prevent it from being upgraded, but the hooks are still there unless you’ve removed them.

3 Likes

Yup - I removed the hooks from places they were unneeded - before they were triggered as far as I know. The more interesting thing was the collision between 2 packages from different sources coming up with 2 identical names (and, presumably, purposes). The IgnorePkg prevented the collision from continuing, and allowed the upgrade to proceed…

The repo isn’t what triggers the logo change. It is the hooks you might be missing now.

That is probably true but probably not the best solution. That is what --overwrite helps with.

Overwrite was unable to help, because the files were not yet present - both packages, with the same intended filenames, were coming in on the same update ‘session’ - which of course caused an error. Ignore caused one of them Not to be processed, and allowed the other to complete its (legitimate) task.

Not something I’ve seen before (even 1 name collision), but I thought it was kinda neat.