EndeavourOS refuses the partition the drive?

I’m not sure sure how I can put this both in Newbie and Installation, so I chose the one that seemed the most appropriate.

I’m trying to install Endeavour, but when I select my partitions and try to install, the installer throws the following error:

The installer failed to resize partition /dev/nvme0n1p3 on disk 'SAMSUNG MZVLB1T0HALR-00000'

Shrink Partition ‘/dev/nvme0n1p3’ from 933.12 GiB to 732.74 GiB.

Job: Check file system on partition ‘/dev/nvme0n1p3’

Command: ntfsresize --no-progress-bar --info --force --verbose /dev/nvme0n1p3

Checking partition ‘/dev/nvme0n1p3’ before resize/move failed.

I tried to install Endeavour a few times using an older ISO (the one released on the 3rd) and while it failed the first time, it succeeded the second time. However, while shutting down the live system I held the power button on my laptop because a long stream of text appeared which looked like error messages. I think that’s the reason why all future installs didn’t work. I’m not sure what to do, can someone help?

hello @requiem
Welcome. So you have had Endeavour installed before and something happened and now you are trying to reinstall it? Was it installed by itself or with Windows?

Would you be able to post the following commands?

sudo lsblk

sudo fdisk -l

Welcome, before using calamares to install the system and resize the partition, I advise you to do it with gparted since calamares does not always manage to do it. After resizing the partition install the system.

sudo su
pacman -S gparted

Execute gparted to root

sudo su

I see you have an NVMe drive.
Happened to me also, solved by manually partition the drive before the actual installation.

Hi everyone, sorry for being so late to reply, timezones are weird for me and I didn’t think people would reply that fast.

sudo lsblk gives the following:

loop0         7:0    0   1.5G  1 loop /run/archiso/sfs/airootfs
sda           8:0    1  29.3G  0 disk 
├─sda1        8:1    1   1.6G  0 part /run/archiso/bootmnt
└─sda2        8:2    1    64M  0 part 
nvme0n1     259:0    0 953.9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part 
├─nvme0n1p2 259:2    0   128M  0 part 
├─nvme0n1p3 259:3    0 933.1G  0 part 
├─nvme0n1p4 259:4    0   900M  0 part 
└─nvme0n1p5 259:5    0  19.5G  0 part 

sudo fdisk -l gives:


sk /dev/nvme0n1: 953.89 GiB, 1024209543168 bytes, 2000409264 sectors
Disk model: SAMSUNG MZVLB1T0HALR-00000
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: DAE9DCA9-DA68-4D48-98FB-55D5A92AD775

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 616447 614400 300M EFI System
/dev/nvme0n1p2 616448 878591 262144 128M Microsoft reserved
/dev/nvme0n1p3 878592 1957783818 1956905227 933.1G Microsoft basic data
/dev/nvme0n1p4 1957787648 1959630847 1843200 900M Windows recovery environm
/dev/nvme0n1p5 1959630848 2000408575 40777728 19.5G Windows recovery environm

Disk /dev/sda: 29.26 GiB, 31406948352 bytes, 61341696 sectors
Disk model: Cruzer Blade
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x193d59cb

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 0 3371807 3371808 1.6G 0 Empty
/dev/sda2 164 131235 131072 64M ef EFI (FAT-12/16/32)

Disk /dev/loop0: 1.52 GiB, 1618071552 bytes, 3160296 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

I’m not entirely comfortable with partitioning the drives because this is my first time using Linux, but I’ll try my best! Is there any step-by-step process to partitioning the drives in EndeavourOS?

gparted is included by default and is a very good graphical tool for partitioning. Also it is set up so that it doesn’t actually DO anything until you tell it to, so you can triple check everything before committing to it.

Yeah, I’m watching a tutorial for it right now. It’s Ubuntu, but I’m pretty sure that it’ll be the same here as well. Will update this thread on what happens after I partition w/GParted

@requiem I have looked at your post and i see the Windows 10 partitions. Just wanted to ask that you make sure you turn off secure boot and fast boot in Uefi before you start trying to do any installation. You stated it succeeded the second time but i see no evidence that any install happened. I only see your Windows partitions and the partitions for your jump drive. Hope the tutorial helps you understand how to use gparted.

Well, I’m back. Long story short, I messed up while using gparted and managed to delete my whole hard disk, so I reinstalled Windows 10, and now Endeavour installs successfully. I’m facing problems with booting it, but I’m sure I’ll figure that out soon.

Glad to see you taking it all in stride. :neutral_face: The learning curve sometimes has it’s setbacks but happy to see you Endeavour!


You mentioned issues with booting EOS. I have found on that after installing EOS on my laptop, I always have to open gparted after installation and manually set the boot flag. No issue on virtualbox, but when installing on my hard drive, the boot flag is not automatically set.