EndeavourOS on a macbook


I’m looking to bring back to life a 12" macbook (macbook10,1) and I’m thinking of going with EndeavourOS with i3. Is this feasible at all? At first glance (booting from a USB stick) it seems that keyboard and trackpad are not recognized by the installer. Can anyone comment if it’s possible to get a somewhat complete system up and running?

Thank you!

I don’t want to jump the gun from the dev’s, but Endeavour i3 might be a tough choice. While the install should more than likely get your keyboard correct, I can’t imagine all of the key combo bindings will work without Fkeys in the same way they do on a “Normal PC.” You will more than likely need to make a lot of changes to the default config for the keyboard layout.

I haven’t tried it though. All of the normal DE’s that are available should work just fine though. Window Managers might be tough.


@fbodymechanic thanks for the input! good point about keyboard layout. Perhaps I should go with a more traditional desktop…

Still I’m having the issue that they keyboard is not recognized at all during the installation. Does anyone know a workaround? Thank you.

What is the model of the MacBook?

And do you have a keyboard wired or wireless? Does the touch pad work?

It’s MacBook 12" Early 2015 model A1534.

Both the touch pad and the keyboard of the laptop does not work. I plugged an USB mouse and external keyboard to go through the installation process at least, but obviously it’s not ideal…

Ok, so I know there’s more mac savvy members here (I think @SGS ? Could have some insight) but from this link it looks like way back folks were having issues with the keyboard and track pad. There had to be a fix, that was 5 years ago and mac’s are too nice to but play with Linux after 5 years.


I use a macbook air from 2013 or 14 and everything works fine. I’ve only ever had to get the webcam working.

sad i only have linux on 2011 /12 Macbook pro. fast look this what i have

extra/xf86-input-synaptics 1.9.1-2 (57.6 KiB 137.5 KiB) [xorg-drivers] 
    Synaptics driver for notebook touchpads
extra/xf86-input-libinput 1.0.1-1 (37.4 KiB 90.8 KiB) [xorg-drivers] (Installed)
    Generic input driver for the X.Org server based on libinput

hope it help/ point in good direction

Edit…found this! ( Orphaned )

aur/xf86-input-mtrack-git 0.5.0.r2.g0185630-1 (+34 0.00) (Orphaned) (Out-of-date: 2020-09-15) 
    A multitouch X driver using the kernel MT protocol

From an Ubuntu blog, I caught wind of this. According to the AUR it’s technically been merged into the mainline kernel,

Please download and try linux-lts and the linux-zen kernels and headers to see if that works, you can also give this a go.


Please post your inxi info so we can see your specs to help further if this doesn’t fix it.

inxi -Fxxxza --no-host
1 Like

I also see there’s a specific macbook kernel/headers available that could help.


There’s also plenty of information over on the Arch wiki, so it’s well worth having a look there: https://wiki.archlinux.org/index.php/Mac


Greetings: a new EndeavourOS convert here. I can confirm that you can indeed install EndeavourOS on macbook laptops. I successfully install on a Apple MacBook “Core 2 Duo” 2.4 13" (Mid-2010) macbook. And all is working without issues as of now. Only minor issues I experienced was laptop occasionally freezing. This was due to an NVIDIA graphic driver issue. Issue can easily be solved by following the instruction on the EndeavoursOS Welcome app, under NVIDIA users and the NOUVEAU section.

The instructions are as follows.

sudo pacman -R xf86-video-nouveau

sudo nano /etc/mkinitcpio.conf

Then go to the line


And change it into:


Save it with [CTRL+X]

Then type:

sudo mkinitcpio -p linux

Issue solved! Good look and enjoy a great distro.


Welcome @uriel and @doggie ! :smile:

And @doggie thanks for explaining your experience with Mac install! It will be useful for other Mac users.

Mac’s from what I’ve been reading, are very specific to year. I’m really glad the documentation helped you figure it out, I don’t think it’s the same issue as the OP. We’ll figure it out though. Welcome to Endeavour!