EndeavourOS KDE Plasma is constantly getting stuck/freezes

Hi i’m new to EndeavourOS and i haven’t had this issue before, just 3 days ago i still used Solus Linux on KDE Plasma and it wasn’t crashing or freezing just worked prefectly but now after switching to EndeavourOS it constantly gets stuck for like 20 seconds to 1 minute or just freezes so i need to click the reset button on my pc which hurts cuz’ i mostly create programs on my computer so my code is gone

Operating System: EndeavourOS
KDE Plasma Version: 6.0.2
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.6.23-1-lts (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3400G with Radeon Vega Graphics
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 570 Series

Welcome to the community!

It’s possible that what you are experiencing is related to the Plasma 6 update or your installed kernel. Please take a look at the thread here for some tips.

Also, in a terminal, please run then post the output of

inxi -Fxxxz

Thanks For Your Help!, but it still didn’t fix the problem and at first i thought that my kernel would be doing that then so i tried updating from 6.6.23-lts to the 6.8.2 but it like could not update it with whatever method i tried

inxi -Fxxxz output:

Kernel: 6.6.23-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A wm: kwin_x11 vt: 2 dm: SDDM
Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: ASRock model: A320M-DVS R4.0
serial: uuid:
UEFI-[Legacy]: American Megatrends v: P3.70 date: 11/14/2019
Info: quad core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64
type: MT MCP smt: enabled arch: Zen/Zen+ note: check rev: 1 cache:
L1: 384 KiB L2: 2 MiB L3: 4 MiB
Speed (MHz): avg: 2414 high: 3030 min/max: 1400/3700 boost: enabled cores:
1: 2399 2: 2998 3: 2540 4: 1230 5: 3030 6: 2981 7: 2907 8: 1232
bogomips: 59218
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
driver: amdgpu v: kernel arch: GCN-4 pcie: speed: 8 GT/s lanes: 8 ports:
active: DP-3,HDMI-A-1 empty: DP-1,DP-2,DVI-D-1 bus-ID: 01:00.0
chip-ID: 1002:67df class-ID: 0300 temp: 43.0 C
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3520x1444 s-dpi: 96 s-size: 928x381mm (36.54x15.00")
s-diag: 1003mm (39.49")
Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,top-left
model: AOC 24V2W1G5 serial: res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: max: 1920x1080
min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: bottom-r model: Philips FTV
serial: res: 1600x900 hz: 60 dpi: 64 size: 640x360mm (25.2x14.17")
diag: 734mm (28.9") modes: max: 1600x900 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 570 Series (radeonsi
polaris10 LLVM 17.0.6 DRM 3.54 6.6.23-1-lts) device-ID: 1002:67df
API: Vulkan v: 1.3.279 layers: 5 surfaces: xcb,xlib device: 0
type: discrete-gpu hw: amd driver: mesa radv device-ID: 1002:67df
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1
chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 07:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.6.23-1-lts status: kernel-api
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
port: e000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 924.07 GiB used: 97.91 GiB (10.6%)
ID-1: /dev/sda vendor: A-Data model: SU630 size: 447.13 GiB
speed: 6.0 Gb/s tech: SSD serial: fw-rev: 129a scheme: GPT
ID-2: /dev/sdb vendor: SanDisk model: SSDPR-CX400-512-G2 size: 476.94 GiB
speed: 6.0 Gb/s tech: SSD serial: fw-rev: 373 scheme: MBR
ID-1: / size: 468.38 GiB used: 97.91 GiB (20.9%) fs: ext4 dev: /dev/dm-0
mapped: luks-505d9e64-2886-4d52-af33-3212fdfd7b92
Alert: No swap data was found.
System Temperatures: cpu: 43.9 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1306
Memory: total: 16 GiB available: 15.55 GiB used: 6.18 GiB (39.8%)
Processes: 318 Power: uptime: 8h 56m states: freeze,mem,disk suspend: deep
wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
Packages: 1146 pm: pacman pkgs: 1139 pm: flatpak pkgs: 7 Compilers:
gcc: 13.2.1 Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33

Show us what happens if you run this command

sudo pacman -Syu linux linux-headers

i have the video on streamable.com so i’ll give you the link
and after rebooting it did nothing

You need to select the kernel on boot menu, as long as LTS one is default it will boot this one instead they persist side by side

I would suggest you update the UEFI Firmware (Bios) as yours is way out of date. Matter of fact there is a Beta version for 2024. Please read through the updates carefully as some versions require you to update to a certain version before you can update to it.

Hopefully I have the correct motherboard here:

Edit: Your current Bios version is:
American Megatrends v: P3.70 date: 11/14/2019

Edit: Best way to update is with instant flash following these instructions.


thanks it works i just needed to go to advanced options for endeavour OS in grub and there it was just linux-lts and linux and now i am on kernel 6.8.2 but i am still experiencing issues with stability one time i was playing a game with proton and my PC just rebooted randomly and after that i started playing again and it just turned off by itself

Everyone i have fixed it completely!,

  • it doesnt freeze or gets stuck anymore
  • the new kernel at first was a struggle for my pc but it got along with it
  • plus now its even faster with the 6.8.2 kernel and not the 6.6.23-lts
1 Like

could you please mention how you solved the issue so others who come across the thread in the future can find the solution as well.

There have been a massive amount of updates on Kde lately. Did it just resolve itself with some of these new updated packages?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.