EndeavourOS Install stuck at first step

I’m at my wit’s end
I cannot install EndeavourOS Arm on a Raspberry Pi 4B
calamares stuck at:
“initialize pacman … copy pacman mirrorlist and keyring”
then after a few minutes it just fails and the sd-card becomes unbootable

Ive tried in 3 different Raspberry PI 4 (2 different 4b and a CM4) and its always fails in the same way.
What am i doing wrong?
Any help would be profoundly appreciated!!!


Hi @tiagol and welcome to EnOS’ community!

I have been trying to install EnOS ARM and can confirm that this issue happens on my end as well.
I have wanted to report but It just got postponed.

I have used method two as described here.

Downloaded the latest ddimg: https://github.com/endeavouros-arm/images/releases/tag/ddimg-rpi-20230502

Checked the sha sum.

I have tried to write the image to both a micro sd card and a SSD using gnome-disk-utility and rpi-imager.

I have tried on both RPi 4b (8GB) and RPi 400.

When launching the installer and past the initial steps, the installation gets stuck at the same step as you have described. It could stay like that for anything about 15 to 20 minutes before the live session crashes.


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

@tiagol @pebcak
Thanks for reporting this, I will do a test install and see if I can duplicate the problem. If pebcak can’t get it installed, then most likely there is a problem.

More later



I was right, I was able to duplicate the problem.

I used Method 1 with the cassini neo R1 liveISO and installed to a 16 GB uSD.
I chose ext4 and it downloaded and installed rootfs-rpi-20230502

Connected the uSD to a RPI 4b 8 GB device with an Ethernet connection connected to a VPN service.
Edited the Mirror list. (Important)
Chose Community Edition BSPWM
From 0 % to next phase was right at 9 Minutes. Disabling the VPN would have been faster.
Then it just reset back to the original input window.

I am in the process of creating new RPi images to see if that fixes the problem.

More later



Thank you Pudge for taking your time looking into this! :wave:t5:


Hey, that is why they pay me the big bucks…oh wait!


the ddimage just finished compliling. Off to test it.


A storm rolled in, with thunder. So now the little girl in my avatar is sitting in my lap for me to protect her from the thunder.



Ran into bigger problems while trying to create new images.
I am stumped for now, and it’s bed time.

Try again tomorrow



Thanks, Pudge, for looking into this.

1 Like

@joekamprad @dalto @manuel @sradjoker

The new problem is the python 3.10 to python 3.11 update.

After booting the image, openbox brings up the following yad screen.

pressing either “Install Official Editions” or “Install Community Editions” does nothing. No error listed, it just sits there.

The “Edit Mirrorlist” still works as it is simply using nano to edit the Archlinux ARM mirrorlist.

If I start launch.sh (creates the yad window above) in a terminal window, and choose either the “Official Edition” or “Community Edition” I get

calamares: error while loading shared libraries: libpython3.10.so.1.0: cannot open shared object file: No such file or directory

So I am thinking the Calamares for ARM version is quite old and probably needs to be rebuilt to account for the new Python ver 3.11

So I am off to try and rebuild a new Calamares for ARM.

Any help would be appreciated.



Did the storm pass over you without harm?

possible to symlink libpython3.10.so.1.0 on libpython3.11.so.1.0 (/usr/lib/libpython3.11.so.1.0) on the live session… before pressing one of the buttons… but could also lead to another bad lib… in case someone want to install at this very moment…


Yes, all we got was rain and noise. Further east of here got golf ball sized hail, and lot’s of damage.


1 Like

Hi all, my first message :slight_smile:

I would like to try EnOS in my Odroid N2+ but have the same problem with 20230502 image.

Just as a workarround, It’s possible to replace “latest” image with an older one and, after installation, just update the system to get the latest version of EnOS?

I tryed to find a previous image without luck, maybe if someone has a working link would be enougth


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

The Python ver 3.10 to 3.11 update caused the problems.

That should be solved by compiling a new Calamares. However, ARM was still using the old Calamares structure and that is no longer a viable option. I am in the process of trying to convert the Calamares ARM PKGBUILD to the new structure. I am getting closer, but still not there.

Sorry for the inconvenience, but things will be better once it’s done.



Hi Pudge, understood, thanks for the welcome, the explanation and for your time!


more one way do install ( if will there ) you can install manual ! choice your.

my rpi4 + N2plus in use for other thing . just show you it work, i install EOS- sway in ARM vm ( my guess it work on metal also)


Thank You, Thank You, for your patience on this issue. :pray:

I finally ended up just jumping into the deep end of the Calamares pool. I took on some water, but I didn’t drown.

I have created new images for the RPi 4b.

Test bed. RPi 4b 8 GB RAM.

Test 1
rootfs ext4 on a 16 GB uSD card installing KDE Plasma using Method 3 - successful

Test 2
rootfs ext4 on a 16 GB uSD card installing BSPWM using Method 1 - successful

Test 3
ddimg ext4 on a 16 GB uSD card installing LXQT using Method 2 and gnome-disk-utility to burn the image - successful.

At least one test install was performed on rootfs and ddimg.
At least one test install for Official Editions and Community Editions.
Three DE / WM were tested.

Did NOT test btrfs

The new images are at

Have at it Guys. Consider these as being test installs, and please report your results back here.

@jtaparicio @joekamprad

I will hopefully get to Odroid N2 tomorrow. It’s past my Bed time. :sleeping_bed:



The Odroid N2+ images are available as

They were tested on an Odroid N2+ using a 16 GB uSD card.
KDE Plasma was installed on the rootfs image and BSPWM was installed on the ddimage image.


1 Like

ddimg-odroid-n2-20230601 installed with plasma, everything is working smoothly

I was using Manjaro but had problems with wayland sessions and composite, system hangs specially using web browsers and video (youtube for example). In X11 sessions without composite Manjaro works but with some graphicas artifacts like cursor flickering.

EnOS very stable with wayland, composite and desktop efects. I get about 50% more fps in webgl fishtank test than Manjaro.

Thanks Pudge for your work!


You are welcome.

Thank you for the feed back.

If I only have FIrefox running, and only a few tabs, Firefox is acceptable. If I load the system down, such as compiling, and using three or 4 tabs for internet research, then Firefox acts up.
Chromium works well but I don’t like to use it.

Just out of curiosity, did you install to a uSD card or eMMC card?