EndeavourOS Install stuck at first step

uSD card for testing. Now I’m installing software (clementine, yakuake, chromium, Calibre, minidlna, transmission, nodered…) and configuring the system (adding zram, plasma theme…)

When everything is installed and if there are no problems I’ll move the system to eMMC card.

What is your opinion about using zram as swap?

Very wise indeed. Only installing to eMMC after this process avoids excess wear and tare on the eMMC.

Since the Odroid N2+ only has 4 GB RAM, using a swap file instead of a swap partition makes sense.

Since I run the Odroid N2+ on a 500 GB USB SSD I have plenty of space for a swap file.
However, running on a USB SSD doesn’t provide HDMI audio, but I use this Odroid N2+ as my compiling for all aarch64 images, etc. so audio isn’t necessary for this use case.


1 Like

Still the same problem:
calamares stuck at: “initialize pacman … copy pacman mirrorlist and keyring”

My installation failed shortly after “initialize pacman … copy pacman mirrorlist and keyring”.

This was a re-install on a Pi4 – the original install (a few weeks ago) was successful.
The ‘setup failed’ message was:

<class 'ImportError'>
/usr/lib/python3.11/lib-dynload/math.cpython-311-aarch64-linux-gnu.so: undefined symbol: _PyModule_Add

File "/usr/lib/calamares/modules/packages/main.py", line 19, in <module>
    import subprocess

  File "/usr/lib/python3.11/subprocess.py", line 119, in <module>
    import selectors

  File "/usr/lib/python3.11/selectors.py", line 11, in <module>
    import math

Install log posted to internet, the url is https://termbin.com/4wq0m