EndeavourOS fails to create new partition during Installation

It seems like I was just gushing about how well installation went on my laptop.

Oh well. This happens.

I really enjoyed the experience on my laptop so I tried to install on my desktop, which has Windows and Manjaro in a dual boot on the same WDC drive.

The condiguration looks like below.

Note that the empty partition is where Manjaro used to be, and where I attempted to install EndeavourOS.

The Error message is as follows.

For the time being, I’ve reloaded a timeshift backup to restore Manjaro.

If you guys know a fix for this, please let me know.

Oh, and apologies for photos, I can’t screen shot them and post them on the main machine…

It seems like deleting Manjaro has created issues with GRUB.

I now boot into grub recovery mode.

I tried following the steps here to fix this but now i just get a black screen…

Aight guys Update.

Before, I manually installed, I wanted to do the easier method and make sure Windows wasn’t broken.

I installed Fedora on the empty partition hoping Anaconda could fix Grub for me(I have like 10 different distros on 10 different USBs just in case) and it worked!! Windows is back up amd booting. I repeat. Windows I booting

Update 2

OMG I LET WINDOWS UPDATE RUN FOR INE TIME AND IT FUCKING NUKED IT SELF ALDKFKDNEKWODNFOVDPWNKWNCOCNDKFFKKFFNDJCKSOWK

1 Like

Try deleting the partition before starting the installer. Then let the installer install into the unpartitioned space.

1 Like

Ok, now even Manjaro fails to install with a similar error

Yep, tried that. Didn’t work.

Thanks for the suggestion.

They both use the same installer(calamares).

In that case, do the partitioning before you start the installer. Then use manual partitioning in the installer to assign the partitions.

3 Likes

I’ve actually never done a fully manual install of Linux before… I guess it’s time I learned. Is there any resources That I should follow before starting?

1 Like

It’s a little old now but should still be valid.

3 Likes

Not sure what your situation is, and why exactly do you need Windows, but to eliminate all the problems at once i would:

  1. Backup all data from this drive
  2. Completely wipe all partitions and dual-boot
  3. Set gpt table
  4. Format to ext4 or btrfs, partition it like you want
  5. Install only EndeavourOS and never look back :upside_down_face:

But that’s just me :wink:

1 Like

Well mate, My sister uses this pc too, and shot don’t give a shit about Linux

1 Like

I don’t see any mention of if Windows is still booting fine. First thing I’d do is make sure it is, and if so follow the instructions @Elloquin posted.

1 Like

Good point, otherwise his sister probably will commit some serious crime! :rofl:
We gotta hurry up :slight_smile:

3 Likes

Yes. Windows is not booting fine.

I repeat windows is not booting fine.

2 Likes

In that case if it a must to keep you from being murdered see if you can fix that first or do a fresh install of Windows if you have no other choice and then install EndeavourOS.

1 Like

Is it possible to retain all the installed app when reinstalling using a Windows USB?

NO, unfortunately unlike Linux you’ll need to reinstall and setup everything. I’d suggest Either sevenforums, eightforums, or tenforums depending on which version of Windose you have and see if they can first help you getting the currently installed Windows back up and running.

1 Like

Ayayay. My aister is gomma kill me…

Doubt it, besides as far as i understood, you just need to fix it’s boot partition somehow, doesn’t look like you’ve killed data itself…

There are plenty of people here who can help, @Root perhaps?

If you don’t hear from me tomorrow, it was my sister.

2 Likes

Check this out, should be valid

Restoring a Windows boot record

specifically

Oh and btw make sure Secure boot and Fast boot are disabled in BIOS/UEFI, but i’m sure you know that already :slight_smile:

2 Likes

Agree I think the data is probably perfectly fine, but I do strongly recommend going to whichever of those 3 forums to get help fixing your Windows boot loader, and then come back here for us to help you with the EOS install.

1 Like