EndeavourOS fails to boot - Stuck at blinking cursor

Hi, I am having the same problem, but not after installing but rather it just wouldn’t reboot all of a sudden a few days back. I tried some troubleshooting based on the problem (Not necessarily coherent info), but nothing worked. I reinstalled from the latest iso, it worked, even updated a few times, but then again it failed on a reboot, and I just re-installed again, and am afraid to run updates or reboot.

I have an MSI GeForce GTX 1050 which I don’t believe should be affected by the dropped support, as all I could find is that 900 series and lower were dropped, not higher.

It also won’t boot in “Fallback” mode.

here is my KDE Sys readout:

Operating System: EndeavourOS
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.5-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2500K CPU @ 3.30GHz
Memory: 31.3 GiB of RAM
Graphics Processor: NV137

Here's inxi -Fxxxz after re-installation:

System:    Kernel: 5.15.5-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2
           wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
Machine:   Type: Desktop Mobo: ASUSTeK model: SABERTOOTH P67 v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 3602
           date: 11/01/2012
CPU:       Info: Quad Core model: Intel Core i5-2500K bits: 64 type: MCP arch: Sandy Bridge rev: 7 cache: L2: 6 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 26492
           Speed: 1605 MHz min/max: 1600/3700 MHz Core speeds (MHz): 1: 1605 2: 1605 3: 1605 4: 1605
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI driver: nouveau v: kernel bus-ID: 01:00.0
           chip-ID: 10de:1c81 class-ID: 0300
           Display: x11 server: X.org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting unloaded: fbdev,vesa
           alternate: nouveau,nv resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
           bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
           Device-3: BEHRINGER UMC204HD 192k type: USB driver: snd-usb-audio bus-ID: 5-2:2 chip-ID: 1397:0508 class-ID: fe01
           Sound Server-1: ALSA v: k5.15.5-arch1-1 running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe driver: e1000e v: kernel port: f040
           bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
           IF: eno1 state: down mac: <filter>
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
           IF: wlan0 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-1.3:4 chip-ID: 8087:0a2b
           class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block: hardware: no software: no
           address: see --recommends
Drives:    Local Storage: total: 6.15 TiB used: 3.01 TiB (49.0%)
           ID-1: /dev/sda vendor: SK Hynix model: HFS256G32TNF-N2A2A size: 238.47 GiB speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 0P10 scheme: GPT
           ID-2: /dev/sdb vendor: Seagate model: BarraCuda SSD ZA250CM10002 size: 232.89 GiB speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 1024 scheme: GPT
           ID-3: /dev/sdc vendor: Seagate model: ST4000NM0035-1V4107 size: 3.64 TiB speed: 3.0 Gb/s type: HDD rpm: 7200
           serial: <filter> rev: TN05 scheme: GPT
           ID-4: /dev/sdd vendor: Western Digital model: WD1001FALS-00J7B1 size: 931.51 GiB speed: 3.0 Gb/s type: N/A
           serial: <filter> rev: 0K05 scheme: GPT
           ID-5: /dev/sde vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s type: SSD serial: <filter>
           rev: 2B6Q scheme: GPT
           ID-6: /dev/sdf vendor: Seagate model: BarraCuda SSD ZA250CM10002 size: 232.89 GiB speed: 6.0 Gb/s type: SSD
           serial: <filter> rev: 1024 scheme: GPT
Partition: ID-1: / size: 191.95 GiB used: 9.92 GiB (5.2%) fs: ext4 dev: /dev/sda2
           ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 30.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 238 Uptime: 54m wakeups: 0 Memory: 31.32 GiB used: 2.92 GiB (9.3%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 Packages: pacman: 1055 Shell: Bash v: 5.1.12 running-in: konsole inxi: 3.3.07

Any help narrowing down the problem would be of great help!

Looks like your system is running on nouveau open source drivers. Did you have nvidia installed?

Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Micro-Star MSI driver: nouveau v: kernel bus-ID: 01:00.0
           chip-ID: 10de:1c81 class-ID: 0300
           Display: x11 server: X.org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting unloaded: fbdev,vesa
           alternate: nouveau,nv resolution: <missing: xdpyinfo>

Edit: Your topic say’s fails to boot after update. But you said I just re-installed again, and am afraid to run updates or reboot. This is confusing. If it’s installed again it will be right up to date and already have those updates that caused it to fail to boot because Eos installs everything up to date if doing the online install.

Edit2: Currently it has the nouveau open source drivers.

If you need help installing the nvidia drivers i can advise you on that.

To be fair, I named the topic when I split it out from a different topic. The title may not be representative.

@Zoidmo feel free to edit the title to something that makes sense.

1 Like

Well, I had NVIDIA drivers installed when the system first failed. Have Nouveau now, because I just haven’t installed NVIDIA yet (May have missed the choice on install if there was one). Since this is my second re-install, because it failed again shortly after I reinstalled a bunch of software, it did so with nouveau drivers, so maybe it’s not a graphics driver issue at all, but failing for some other reason.

Either way, it would help to find out exactly what is causing it, if it happens again, but I can’t get a TTY in that state, as it’s in the very beginning of kernel load, possibly even grub (I do get the pinkish screen with grub boot choices though).

Did you have the optional enhancements set up for nvidia?

Right now, nothing seems to make sense: Well I just can’t make sense of it for sure! :sob:

Maybe, maybe not, :face_with_raised_eyebrow: I’m not sure what you are referring to.

You need to have nvidia-installer-dkms installed first if it’s not to install nvidia. So if it’s not installed then.

sudo pacman -S nvidia-installer-dkms

Then what i would do is install the nvidia drivers with the installer.

sudo nvidia-installer-dkms

Once the install is completely finished don’t reboot.

Now you want to add all the enhancements as per the wiki.

sudo nano /etc/default/grub

add this to the default grub command line

nvidia-drm.modeset=1

Looks like this as an example:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 resume=UUID=...

Then save the file

ctrl + o then enter to save
ctrl + x to exit nano

Then run

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then

sudo nano /etc/mkinitcpio.conf

add this to MODULES =

MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"

ctrl + o then enter to save
ctrl + x to exit nano

Then run

sudo mkinitcpio -P

Then

sudo nano /etc/X11/xorg.conf.d/20-nvidia.conf

add this to the file so it is the same

Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
EndSection

Section "Screen"
        Identifier      "nvidia"
        Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"
EndSection

ctrl + o then enter to save
ctrl + x to exit nano

Then install the hooks package

sudo pacman -S nvidia-hook

reboot

Edit Your card should be supported by the current nvidia drivers.

1 Like

nvidia-installer-dkms is already installed.

Install NVIVDIA drivers, not a problem, but as to

“Now you want to add all the enhancements as per the wiki.”:

Are you asking me to read the wiki, and follow it’s steps, or are you giving me the actual steps with additions? If the former, what wiki (Link please), if the latter: I will follow your steps, but in case of disaster, it may be a while for me to be back here, but I will do so from the live media, ready to chroot and find the problem, if someone can lead me through the steps to narrow it down.

I gave you all the exact steps but you can look at the wiki if you want. I just said when you install the nvidia drivers don’t reboot until you have all the enhancements added and complete. I also said install the hooks package rather than creating the file as it does the same.

Edited above.

I just can’t not do it. . .

(NSFW for anyone about to watch it)

I’m not fair, when it comes to beer! I want it all! :rage:

When I went to changing /etc/default/grub found this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 nowatchdog nvidia-drm.modeset=1"

So it’s already there, unless it should come first, like this:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 quiet loglevel=3 nowatchdog"

No “resume=UUID…” in there though?!?

What ever is there is fine. You used a newer ISO which has been updated. It doesn’t have to be in order and my line is just an example so don’t go by it.

Edit: Resume is for hibernation i think.

1 Like

OK, ready to reboot :grimacing: :nauseated_face: :face_with_thermometer: :hot_face:!

I hope you don’t tell me? :crossed_fingers:

1 Like

I just realized i did forget one thing and that was to update grub. But you already have those entries so we should be good. :slightly_smiling_face:

I’m telling myself I’m getting worried now?

Edit: @Elloquin jinxed me… :laughing:

I’m back :smiley:, and successfully rebooted.

Not safe yet, as the last time it crapped out, there seemed to be no apparent reason, no warnings, NO NOTHIN’!

Wouldn’t it be nice if Linux had an automatic troubleshooting AI bot built in, that just sprang into action at the first sign of trouble? Well, so far all “AI” I have seen was all “A” and no “I”! :stuck_out_tongue_winking_eye: