EndeavourOS bootloader missing after BIOS update (dual boot)

Hello everyone, I recently installed EndeavourOS and I am loving it. I keep windows (different ssd from linux) mostly for gaming and sadly, yesterday my Legion 5 Pro decided to update the bios and now I cannot boot into endeavouros. I tried setting the boot order but my linux ssd shows as windows bootloader and thus I cannot set it from the bios. I already downloaded and flashed a usb drive so that I will try to fix it from there. Could you guide me through? I saw some related/similar issues but since I am quite new, I wouldn’t want to risk messing it up completely. Thanks in advance :smiley:

Hi @gregory and welcome to EnOS’ community!

Could you please boot up your Live USB and post the output of the following commands?

sudo parted -l


Copy the terminal output as text an paste it to your reply box, highlight it and press Ctrl-E to format for better readability.

1 Like

Installing a new bios often resets it to default options. You may have to go into the new bios and adjust accordingly. Especially turn off secure boot and CMS.


1 Like

disable secure boot

Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sda: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15.5GB  15.5GB  primary  fat32        boot, lba

Model: Samsung SSD 970 EVO Plus 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name         Flags
 1      2097kB  1051MB  1049MB  fat32                        boot, esp
 2      1051MB  483GB   482GB   ext4            endeavouros
 3      483GB   500GB   17.5GB  linux-swap(v1)               swap

Model: SAMSUNG MZVL21T0HCLR-00BL2 (nvme)
Disk /dev/nvme1n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  274MB   273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB   16.8MB               Microsoft reserved partition  msftres
 3      290MB   1022GB  1022GB  ntfs         Basic data partition          msftdata
 4      1022GB  1024GB  2097MB  ntfs         Basic data partition          hidden, diag

The first one is the usb that I booted from, then the linux and then the win11 ssd.
Also secureboot is disabled but the same options appear on my bios boot order. The linux ssd appears as windows

1 Like

Could you send the output from the command above as well?

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0004,0000,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,f1797e56-6e5f-cc45-a181-5c28a92c9a26,0x1000,0x1f4000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* EFI USB Device (KingstonDataTraveler 3.0)	UsbWwid(951,1666,0,60A44CB2B34EE340A71A05D)/HD(1,MBR,0xadaa02,0x800,0x1cdf800)RC
Boot0002* EFI PXE 0 for IPv4 (6C-24-08-A3-12-4B) 	PciRoot(0x0)/Pci(0x2,0x3)/Pci(0x0,0x0)/MAC(6c2408a3124b,0)/IPv4(,0,0)RC
Boot0003* EFI PXE 0 for IPv6 (6C-24-08-A3-12-4B) 	PciRoot(0x0)/Pci(0x2,0x3)/Pci(0x0,0x0)/MAC(6c2408a3124b,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0004* Windows Boot Manager	HD(1,GPT,a4ae3479-23b6-4c85-9ed4-9c9215776599,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

Here you go

1 Like
Boot0000* Windows Boot Manager	HD(1,GPT,f1797e56-6e5f-cc45-a181-5c28a92c9a26,0x1000,0x1f4000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)
Boot0004* Windows Boot Manager	HD(1,GPT,a4ae3479-23b6-4c85-9ed4-9c9215776599,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)

Indeed it looks like that the BIOS update has wiped out the EFI boot entry for EnOS and somehow created a second Windows Boot Manager. Or the second WBM is the remnant of a previous Windows installation since it appears to be on the same disk and partition but different PARTUUID.

First, let’s see if we can create a new boot entry for EnOS.

Judging by the size of the ESP on your Linux disk, I suppose you are using systemd-boot and not Grub.

If systemd-boot, please follow the following instructions: In the live session

sudo mount /dev/nvme0n1p2 /mnt
sudo mount /dev/nvme0n1p1 /mnt/efi
sudo arch-chroot /mnt

Now in chroot:

bootctl install

Next type exit followed by enter to quit chroot.

Check with efibootmgr to see if a new EFI boot entry for Linux has been created.

If it is first in the boot order then fine. If not, go into BIOS settings and give it first boot priority.

It’s possible to use efibootmgr as well to change the boot order:

sudo efibootmgr -o xxxx,yyyy,zzzz ..... replacing the letters by the actual boot numbers.

If you are using Grub, let me know to give you the relevant command lines.

Also, it would be good to see the output of

sudo blkid


Works perfect! Thank you so much for your help and effort. At first the laptop screen was set on the lowest resolution but after sudo pacman -Syu everything was back to normal. I suppose on the next bios update the same rules will apply if the bootloader goes missing again. I will try to check it first from a a live session and if the outputs are similar to those above, I will try the same commands as now.

1 Like

I am glad to hear that everything worked out and you have your system back up and running.

And also welcome to EnOS’ community @gregory !

:enos: :wave:t5:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.