Endeavour OS with BTRFS & BSPWM

I have been trying to install Endeavour OS (BSPWM) with BTRFS but it fails everytime… installs perfectly with ext4… any suggestion for me. also installation takes more than 1.5hours to complete in both in disk setup and community edition…

Can you share the exact error you are getting?

currently i am on archlinux… i was thinking of installing it tonight… i don’t remember completely but it said failed to install endeavour os, unable to create partitions… but worked great with ext4… iam going to install it now and will share the error i get… last time i checked… it took 2hrs for the installer to complete partitioning then i got the error… just give me some time…

1 Like

@BlaankkSpacee Welcome to the forum and EndeavourOS.

2 Likes


well this is new… i never got this error… what to do here

thank you

That looks like a bad download or a bad flash to USB to me.

1 Like

i actually flased ventoy and copied both endeavour os and arco so that if one fails i could install another just to get the browser ready

I would say it didn’t work based on your output. You might try flashing it more traditionally.

2 Likes

I would say it’s a bad flash (agree with @dalto ). And like to propose using dd to do it. This might help.

I think Ventoy is fantastic, but unfortunately I have had some issues with certain EndeavourOS ISO images. Some work fine, some are just impossible to get working. Some boot up fine, but fail the install… And I don’t know why, which upsets me greatly. So, while Ventoy is a great concept, in practice, I find it to be hit and miss.

1 Like


ok its been like 15-20 mins… 1.5 hrs to go till i get the btrfs partition error

thank god i did a manual partitioning… automatic part around 2 hrs to install… first it gets stuck in 8% then in 42% then in post install 98% then i get the error…

If your internet connection is good the downloading parts will go faster. Online or Community editions are net installers mainly.

1 Like


in my case internet is not the issue


this the position where i get the error for btrfs or it jumps to 98% for post install config for ext4…

stuck here for 30+ mins though

strange… installation is complete without any error… but it still took nearly 1.5 hrs to install… why so ???

I jump right on here will also hear if anyone knows why it took some time to install ES online
i have never tried that it took 1.5 hours
I have 120-150mb internet
but takes 40 min and install
do not know why either and tried another where it took 10-15 min
do not see it as a problem
but could be that someone knows why it takes a long time to install

40min is still alot of time… it should take 20-25min (in worst case)… I tried installing it on vm same 45-50 min… something is wrong… even i have 100Mbps internet… if i install the official packages, it takes 30min… something needs to be fixed…

What you could do is update your mirrors before starting to install.

This can be done by clicking the Update Mirrors button on the Welcome window, or run command reflector-simple on the terminal.
Then read the small instructions (and probably select the closest countries) and let it run.

Then you can start installing.

3 Likes

Side note for next time in the future, when the new EndeavourOS iso is ready and released, it’ll be streamlined for faster downloads to help alleviate issues like this that may happen when mirrors aren’t updated before installing like @manuel suggested. Glad to see you finally got it installed though! Welcome to the forums :slight_smile:

1 Like