Endeavour OS volume doesn't show up after 30 seconds, falls back to interactive prompt

The problem I’m facing is probably coming from Windows, so I don’t know if this is the best place to post this. Please let me know if it’s not and I can delete my post.

I don’t have access to a USB or a CD at the moment, but I wanted to install this EndeavourOS anyway, so I couldn’t completely follow the installation instructions this site provides. I followed the directions (for UEFI laptops) this Ubuntu user gave here (while replacing Ubuntu with EndeavourOS, and without using etcher or UNetbootin), installing refind, making a partition to replace the live USB, up until the point where you’re supposed to extract the ISO to the partition emulating the live USB.

When I try to boot from the partition, it can’t find the device. I believe this is because it’s not named EndeavourOS_202108. Specifically, it’s looking for device dev/disk/by-label/EndeavourOS_202108 so it can mount it at run/archiso/bootmnt. After searching for it for 30 seconds and failing, it says that it’s “Falling back to interactive prompt.”

My problem is that when I try to rename the the partition in Windows to EndeavourOS_202108, an eleven character limit only lets me name it EndeavourOS. Is there a way to get around this? That way I can rename the drive so EndeavourOS knows where to look.

Edit: It turns out this is a problem with the FAT32 format, which only allows for 11 character names, apparently. Is it possible to use a different format for the live usb?

Also, edited the body and title to have more information.

Final edit: Downloading a newer version than current release worked. My real problem was when trying to disable RAID on my SSD so I could install EndeavourOS on a partition of it. But, even though I followed instructions so I wouldn’t ruin my Windows 10 installation (I’m trying to dual boot), I still ruined it and required a system repair. I think I’m going to wait a bit before I try this again, if I do try again. Thanks for the help!

Most devices have USB? What is the reason you don’t have access to usb?

I have USB ports on my device. What I meant is that don’t have access to any flash drives. I think I’d face the same problem on a FAT32 USB, anyway, because that format is limited to 11 characters for its name, based on what I’ve read on forums. Basically, I guess my problem is that the computer says that “‘dev/disk/by-label/EndeavourOS_202108’ did not show up after 30 seconds.” And I assume it’s because the drive has to be named EndeavourOS_202108.

I’m not sure exactly why you are trying to do this as usb drives are a dime a dozen. They aren’t expensive and most people with a computer would have them? Couldn’t you borrow one? But, anyway the image does take a while to load. I’m just not up on the procedure you are trying to use and i would have to attempt it myself to understand what the issue is that you are having and why as I’m not familiar with this way.

Would it help to show what my computer shows me? Here’s a picture of what I run into when I try to load the live installation.

1 Like

this issue is known, the ISO has a labelname that does not respects FAT32 label name restrictions.
This will be changed for next release.

1 Like

I’m glad it will be fixed, so thanks for letting me know that.
In the meantime, is there any way to get around this issue so I can install EndeavourOS anyway? I can reformat the drive if needed.

i send you the info…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.