Endeavour OS doesn't show up in Boot Menu

after a Windows Update my Endeavour OS disappeared from the boot menu. Only following Options show up:

  1. Windows 11
  2. Reboot into Firmware
    I already read the posts from the other ones but in my case after typing efibootmgr there are 2 Linux Boot Manager but still my Endeavour doesn’t appear in there.
    I would be really glad if you could help me.

This is probably EndeavourOS. Have you tried this option?

Ye,s but i also only get this two options.

Right. “Linux Boot Manager” is probably the one you want. That is systemd-boot

Yeah its systemd-boot. And how can i fix it in my case?

Go into your BIOS and set “Linux Boot Manager” as the default.

Alternatively, you can do the same thing with efibootmgr but it is usually easy to just to it in the BIOS menu.

I done that already by setting the first and second Linux Boot Manager in the first two positions.

If you have two of them, try switching the positions so the other one is first.

I tried that also but both only show up Windows 11 and Firmware.

Wait. Can you share a photo of what you are seeing?

From the systemd-boot? or bios

I want to see the screen you see at boot with the choices.

It’s the screen from somoene else. instead of windows 10 there is 11 everything else is the same

is everything clear?

Yes. That looks like an issue with something being missing.

You need to boot off the ISO, arch-chroot in using these instructions. Be sure to mount your EFI partition before chrooting!

Then share the output of these commands:

find /efi
pacman -Q | grep -i -E "dracut|mkinitcpio"

is it also possible to use manjaro iso (i have a usb stick with it on). Because there is something similiar manjaro-chroot.

Eh, it is possible but manjaro is different enough that I can’t advise you on how to do it correctly. manjaro-chroot is different than arch-chroot but I don’t remember the specific differencess.

ok then i will do it with arch-chroot for safety

is arch-chroot an endeavour os command?

It is from an Arch package. The ISO for any Arch-based distro except for Manjaro and Garuda should have it.