Endeavor live USB won't boot to System76 Oryx Pro

I can’t get Endeavor (or ArcoLinux), both Arch based, to boot from a live USB to my System76 Oryx Pro 2018 laptop. In both cases, the boot process begins, and then I fleetingly get the following:

archiso login: liveuser (automatic login)

/home/liveuser/.Xauthority does not exist

nouveau: … init failed with -16
client resume failed with -16

After this the system generally powers off, and sometimes just hangs. I remember that I had a similar issue with trying to boot ArcoLinux months back in similar fashion from a live USB. I tried again today with both distros, with similar results. This seems to be endemic with trying to boot Arch based live distros to the Oryx Pro. I’m trying to find something in the system logs which might give more information, as the process is fast and fleeting as it echos on the terminal during boot. Can you offer any clues as to what might be going on with the Oryx Pro and Arch distros? So far, I’m only able to get Debian/Ubuntu based distros to boot from a USB on this machine. I’m about to get delivery on a new System76 Adder WS laptop, and will see if I get similar results.

Thanks for any input you can provide. I’m also posting this to a support ticket with System76.

hello, you watched if the secure boot is activated or not

Like @JR29 said try to boot with secure boot disabled and also try with this ISO:



I’ve always had secure boot disabled.

Bryanpwo, I’m in the process of downloading the iso you provided. Will report results. I note that it includes nvidia as part of its title, so perhaps there is something to that, given the nouveau failure report.

you make your usb keys with which software, thank you

I’ve created USB keys three ways:

Command line: dd bs=4M if=/path/to/archlinux.iso of=/dev/sdb && sync

PopOS gui: USB Flasher

LinuxMint: USB Image Writer

Each way exhibited the same issues. I’m about to report results from Bryanpwo’s iso.

Perhaps peculiar to my hardware, I had better success installing EndeavourOS via a DVD

Okay, so this iso was unsuccessful but had different symptoms. Here’s briefly what I could jot down while the USB was booting:

Using config directory: "/etc/X11/xorg.conf.d
Using system config directory "/usr/share/X11/xorg.conf.d

Markers: (–) probed, (xx) from config file, (==) default setting
(WW) warning, (EE) error, (NI) not implemented (??) unknown

At this point the boot process hangs. Looking back as far as I was able on the screen, the generated log file is on “/var/log/Xorg.0.log”. After rebooting to PopOS, I’m copying that log file to my /home area for further investigation. BTW, this laptop is triple booted to MX, Linux Mint, and PopOS. PopOS was the original installation, and some time ago after giving up on ArcoLinux (same issues as EndeavorOS) I got the other Debian (MX) and Ubuntu (Mint) based distros to install. The new laptop (System76 Adder) will come shipped with PopOS systemd booted, as was this Oryx Pro 9 months ago. The Oryx Pro, so far, is the only laptop I’ve had to exhibit the Arch iso problems in booting. I have a Dell XPS13 and an HP Omen, about 3 years old, which have no problems with Arch based iso booting and installation.

I investigated in the AUR and I see that there’s a system 76 driver in the database, that solves a lot (like grub parameters and more)
The problem is that this driver must be installed on the Live ISO already to make it work on your system. Maybe I’m wrong, but neither one of us has a system 76 machine and hopefully, another user will come along to help you out with this problem.
(by the way, the ISO is a test build made by @joekamprad)

1 Like

Okay. Thank you for checking it out. I’ll relay this info to the system76 people a.s.a.p.

1 Like

I believe that the Oryx Pro comes with an Nvidia driver.

Try adding modprobe.blacklist=nouveau to kernel by typing “e” when boot menu appears; use an arrow
to go to the end of the kernel boot line and add the phrase modprobe.blacklist=nouveau there (it should follow quiet splash), and then boot the LiveISO.

Try it; it can’t hurt anything so you have nothing to lose. This instruction was given to me on the Antergos forum by joekamprad and it allowed me to install Antergos to an otherwise recalcitrant computer (which also has an Nvdia graphics driver).

I hope that this helps you.


P.S. Next week or the week after I want to install EndeavourOS to that computer; I’m reasonably certain that adding this phrase to the kernel boot menu on the LiveISO will allow the installation to proceed normally. (If it doesn’t, I’ll be back here with fire spewing from my nostrils!)


Just f.y.i., I have no problems getting EndeavorOS or Arcolinux to install on Virtualbox on the Oryx Pro, which of course just loads the ISO from the hard drive. It’s only an issue getting the live ISO USB to boot bare metal. This too might be because the VB’s don’t care about nvidia, using the InnoTek Virtual Box Graphics Adapter.

Will try that next. Thanks!

May i ask what Video card you ordered the Oryx Pro with?

6 GB GTX 1060. The new Adder will have a 8 GB GDDR6 RTX 2070.

Have you tried nomodeset on boot? In the Grub menu?

Please let me know if it works.


Waiting to know if it’s been tried? :grinning: I have the same card on my desktop but it has the Antergos conversion to Arch and then to Endeavour.

this case systemd76-dkms packages from aur will not help much as dkms is good for backlighting control of nvidia,

there no intel gpu also in it ?

edit :
mayby usefull is also what @garybean said basicly : first part not the rest about blacklisting : https://tonymugen.github.io/ArchLinuxSys76OP.html

is it the same .?