Enabling Hibernate

I had an issue I attempted to solve a while back where when I left my system idle, the screens would go black (display sleep?). When this happened, the fans in my computer would ramp up to about 50% speed. This annoyed me, so I followed the following directions to try and disable all sleep, suspend, hibernate options:

This did not fix my issue (and why would it, now looking back I don’t think I realized that display sleep and sleep are unrelated). I never got around to undoing this change. I would love to enable hibernate again so I went ahead with this command:

sudo systemctl unmask sleep.target suspend.target hibernate.target hybrid-sleep.target

When I attempt to hibernate now, still nothing happens. I am able to suspend though.

Also, if anyone knows why my fans are ramping up when display sleep occurs, I’d love to know why and how I can fix it.