Emoji don't show up unless I use the Windows 10 set

I’m not entirely sure what I can say here. I have noto-fonts-emoji installed, I even tried installing noto-color-emoji-fontconfig from the AUR, but the only way I can get emoji to display at all is to uninstall the Noto emoji and use the Windows 10 set that I got with… some Windows font package on the AUR, I’m not sure which one exactly.

I didn’t use to have this issue on vanilla Arch, but it started happening after I switched to EOS a couple of months ago and I wouldn’t mind it if not for the fact that the Windows 10 set is no longer updated because it’s been replaced with the Windows 11 one.

Welcome to :enos: @hazelnot

That’s a weird one :thinking: What desktop environment are you using, as a starting point?

I’m on Gnome. At first I suspected it was related to disabling bitmaps in fonts in fontconfig because without doing that a whole bunch of (Microsoft) fonts looked awful on-screen, but I deleted the thing that did that and it didn’t seem to make any difference at all.

Have you got gnome-characters installed? Do emoji show up in that application when you have just noto-fonts-emoji installed? Do emoji show up when you go to https://getemoji.com/ in your browser?

They don’t show up in either of those places, no.

I uninstalled the package with the Windows 10 fonts, which is apparently what caused things to try to use Segoe UI Emoji and fail but only when Noto Emoji are installed, but still nothing shows up.



Kinda weird that I didn’t have to do this in vanilla Arch but have to do it in an allegedly easier to set up OS but oh well


…although that still doesn’t explain why the Windows 10 colour emoji worked lol

Happy that the :frog: suggestion worked. The most likely explanation is that at some point your system font configuration got messed up, and you’ve now overridden it with fontconfig in your home directory.

Having just noto-fonts-emoji works fine for me (admittedly I am using KDE not Gnome).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.