Dual boot on two separate SSDs

Edit /etc/default/grub and remove # from this line:

Save the file and run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

I just did exactly what you said. windows boot manager is still not showing up…

Alright, I missed that your Windows is installed in Legacy/Bios mode.
Now you have your EnOS’ installed in UEFI mode.

That is why Grub cannot add any boot entry for Windows.
Since this is a pretty new install, I would suggest to reinstall your EnOS in BIOS/Legacy mode as well.

Can you show me which line of the output indicated the Windows was installed under legacy mode? So I can learn. Btw, please see screenshot from my Dell BIOS, it seems like the Windows Boot Manager 's file name is \EFI\ubuntu\grubx64.efi. Since Ubuntu (Linux Mint) was replaced by EOS, is that the reason as well? If it’s due to the Windows in legacy mode, would it be better off if I reinstalled Windows under EFI? Thanks a lot!

For a UEFI mode install, it is a requirement to have an ESP partition. Your Windows’ disk doesn’t have one.

Seemingly Linux Mint has overwritten Windows Boot Manager with its own.
What is confusing to me is why it is \EFI\ubuntu\grubx64.efi which is the typical path for a UEFI install :thinking:

Apparently, your system supports UEFI mode so this could be an option if it is not too much of a hassle.

I was going to suggest another route as well, namely, chainloading the Windows Boot Manager via Grub. However seeing that it might have been overwritten in a previous dualboot, I doubt it would work.

If you are going to reinstall Windows in UEFI and IF you want to keep your both systems ESP and the contained boot files separate, you could do one of the following:

  • Remove boot,esp flags from your EnOS’s ESP before installing Windows
  • Remove the whole disk where EnOS is installed

If not, when Windows installer finds a FAT32 partition with boot,esp flag, it tends to install its boot manager in there.

Also, it goes without saying: backup everything that is important to you on your Windows.

if you want to know for sure what mode windows is installed,
you run windows, put into the cmd-line msinfo32
and see the status in the systeminformation

I recalled doing that after installing my windows, it was indeed in UEFI mode. I think the Linux Mint messed everything up…

At this moment I’m not able to boot into Windows even from the BIOS boot menu. But I recalled checking the System Information in Windows after installation and it was indeed in UEFI mode (another evidence is that the partition table is GPT).

I don’t mind re-install both systems again but I wanna do it correctly this time. What would be the correct way to do it. Windows first then EOS? Thanks again.

Your Windows Boot Manager has been overwritten so that is expected.

It is possible to have BIOS/Legacy boot mode even with a GPT disk if firmware allows that. Some do.

What is not indispensable for a UEFI boot installation, is the presence of an ESP. This is a requirement not something optional. Your Windows’ disk doesn’t have one. So…I don’t know :thinking:

Your EnOS installation is fine.
If you don’t mind reinstalling Windows, I would do this instead.

Take out your EnOS disk before, if you want to keep the ESP:s and boot files/folders separate for the two systems. Or remove boot,esp flags from your EnOS’ ESP.

Good luck!

1 Like

What’s the command to remove the boot,esp flag. Do I need to add it back after installing Windows? Thanks.

In EnOS, open a terminal and run sudo parted to get an interactive prompt.

You can type print (enter) to see all the flags for all the partitions. In your case there is only one partition wit flags:

set 1 boot off

Check with print again. When done press Ctrl-D to quit parted. You might get some message about the fstab. You can ignore it.

You can do it but it is not necessary. I think it is only needed to set the partition type. After the installation the flags are not needed.

If you want to set them, use parted like before but this time:

set 1 boot on

1 Like

Thank you for your patience.

I have another Dell computer which has the same situation. It currently has one SSD with Linux Mint and the other SSD with Win10. If I wanna replace Mint with Arch, what’s the correct way to do it without messing up Windows, learning from today’s lesson. Huge thanks again.

1 Like

Lets’ take one at the time :wink:

No worries. You’ve already helped me a lot ! I just checked system info on the other computer, the Windows is indeed in UEFI mode.

1 Like

We can look at it later on.

Let’s get this dualboot installation going first.

You could open a new thread about the other system and post the output of the relevant commands like you did here previously. We can take it from there.

1 Like

I’m reporting back what I just did this morning:

  1. I didn’t unplug any SSDs for the whole process;
  2. I loaded the Win10 ISO on the USB and booted it from there, then chose the startup repair option, obviously the system informed that it failed to repair. I’m very eager to know why…the Win10 ISO should contain any resources needed for the repair, right? But it wouldn’t even rebuild the Windows Boot Manager?
  3. Then I did the fresh Win10 installation on the 2nd (Samsung) SSD (still, I didn’t unplug the EnOS SSD). The Win10 installation went through but the BIOS booted straight up to Win10 by skipping the EnOS grub.
  4. I had to change the boot sequence in the Dell BIOS by putting EnOS ahead of Windows.
  5. Then I booted into EnOS manually and ran the “sudo grub-mkconfig -o /boot/grub/grub.cfg” command.
  6. Rebooted the computer and now the Windows boot manager DOES show up on grub.

So far my conclusion is: 1. Linux Mint messed up things at first; 2. Impossible to repair the Windows Boot Manager even with the live ISO…

I am not sure about that.

Even though I don’t have any explanation why Windows Boot Manager had an EFI path pointing to grubx86.efi, I am pretty sure that your Windows was installed in Legacy/Bios mode. Reason: the absence of the mandatory ESP.

More, in Legacy/Bios mode, the Linux system as second OS will overwrite the MBR of the disk and cosequently overwriting WBM. This is the normal course of events. When the second OS is removed the WBM needs restoring.

This should be possible. I’m not sure what might have gone wrong.

I’m glad that you finally got your dualboot system up and running.
Please take a moment to mark the post giving you the solution as such for the thread to be regarded as solved by the forum software.

This is correct. If you install Windows it going to boot Windows. It doesn’t pick up linux. The installed bootloader grub is what adds Windows to the menu in grub using os-prober. Normally it would automatically boot on the coirrect drive but this doesn’t always happen. Sometimes you have to set UEFI to boot the drive that has EndeavourOS installed on with the bootloader.

1 Like

what computer is running now ?
the one you had the problems as told in the beginning
or the other one you mentioned in #31

The one I had problem was Dell Optiplex 7070 SFF. The one I’m gonna install an EnOS is Dell Optiplex 7060 MFF.