Dual boot on two separate SSDs

I have 2 SSDs on my PC, one has Linux Mint installed and the other has Windows. The grub menu works perfectly. I replaced Mint with Manjaro and it ruined the Windows a couple weeks ago, so I had to reinstall Windows. I want to install Arch or Endeavour to replace Manjaro. What would be the best or secure way to do it without messing up the Windows SSD and still include it in the grub menu? Should I unplug the Windows SSD before installing Endeavour? If so, what should I do afterwards to add Windows back onto the Arch grub menu? Thank you.

It shouldn’t be necessary to unplug the Windows SSD. Just make sure when you install you are selecting the correct drive to install to. If you have more than one drive there will be a drop down menu that you can access on the installer.

1 Like

I did exactly what you suggested when I installed Manjaro and it did break Windows…can’t figure out why. I tried researching on how to bring Windows back but failed, maybe I didn’t dig deep enough. Thanks.

best to put grub on the same drive as your EOS install. leave the windows drive alone completely

Even though you wouldn’t need to as mentioned before, if you want to be completely sure, you could do it.

Install EnOS or Arch on the other drive. Make sure to install it in the same mode as Windows, that is both systems should be installed either in UEFI or BIOS/Legacy mode.

After installation, plug in your Windows drive. Boot into your EnOS or Arch system.
Make sure you have os-prober installed. Also you would need the following line:


in /etc/default/grub.

Now, regenerate grub.cfg:

sudo grub-mkconfig -o /boot/grub/grub.cfg

This should evoke os-prober which in turn should detect your Windows and create a boot entry for it.

1 Like

I agree you can do this but I don’t understand why people have so many issues with it. I have half a dozen laptops and desktops that dual boot Windows. On some they are installed on the same drive using the Windows EFI and others that are installed on a separate SSD. I have installed EndeavourOS on it’s own SSD using the installer with erase disc and swap file and btfrs or other and it creates it’s own EFI. I never have any issues with it. I have also installed EndeavourOS on it’s own SSD using the Windows EFI if i choose manual partitioning. :man_shrugging:

1 Like

say I wanna create three partitions on the EOS SSD, one for boot , one for root (btrfs) and one for personal data (ext4), (no swap), what would be the mount point for the “personal data” partition? the boot partition will be mounted on /boot, the root partition will be mounted on /root. What would be the mount point for the “personal data” partition? (don’t wanna mount it under /home). Thank you.

I have EOS on one SSD and the default installation of Windows on another SSD.

I never touched a grub entry since day one.

When I want to boot into Windows (once or twice a year) I just select that disk from the boot menu. Then reboot and reselect the EOS disk.

No mess.


what file system do you use for the EOS? I did the manual partition but the system failed to boot after installation. I think I messed something up when doing manual partition. I want to have one root (btrfs) and one data (ext4) partition, so with the boot/efi it will 3 partitions in total…

Partition 1 > type: FAT32 | size: 512 MB | mount point: /boot/efi | flag boot (For Grub)

Partition 2 > type: BTRFS | size: your choice | mount point: / | no flags

Partition 3 > type: EXT4 | size your choice.

When it comes to mount point for the EXT4 partition, it could be theoretically anywhere on the filesystem.

For a data partition, you might find it convenient to mount it under your user directory.
You could do this post-install via en entry in /etc/fstab.

For “user directory”, do you mean /home or /media or /mnt or /usr? Thanks.


You could create a directory called Data (as an example, name it what you like) under your user’s home directory. Then you would need to create an entry in /etc/fstab for it to be mounted there at boot.

Please study the wiki article on fstab:


1 Like

I followed your instruction to install EOS on one SSD and left Windows alone at its own SSD (I didn’t unplug the Windows 10 SSD, though). However, the windows boot manager is still missing on the grub menu… I made sure os-prober is installed and edited the /etc/default/grub, then regenerated the grub.cfg. Could you help me diagnose this further? Thanks a lot! (FYI, the dual boot worked fine between Linux Mint and Win10, now Mint is replaced by EOS)

1 Like

Boot into your EnOS and post the output of the following commands.

Copy the terminal output as text, paste it in your reply, highlight it an press Ctrl-E to format.

sudo parted --list


cat /etc/default/grub

Just something to think about, since I see you say this or some variant constantly in many help threads. . .

If someone has gone out of their way having an issue they actually posted asking for help, and they get" I never have any issues." Or “I don’t understand why so many people have issues with this…”

You may consider how that makes the user, possibly newer to Linux or at least Endeavour feel. Maybe they aren’t even new at all and are struggling with the topic. That of which they probably have never done whatever it is before or even worse- now feels bad because they can’t do it again and they may just think, " only I can screw this up obviously I can’t use this distro, this is so simple no one else ever has problems like this. Hell, this guy even has dozens of laptops and no problems, obviously I can’t do this, I give up and go back to windows."

Literally every time I read you say something about how you have no problems or never issues or it just works whatever, I literally cringe. More than likely if that were true for the other person, they wouldn’t have made the thread. . .

Everything is easier if you’ve done it before. And even a simple task can be difficult on the first attempt for anyone. Please be mindful you’re experience makes things easy.

1 Like

I hear what you are saying but I’m not referring to anyone’s ability or lack there of. I’m just dumb founded why there are so many issues with installing dual boot. That’s all there is to it. Nothing more. I’ve never had to remove the Windows drive when installing on two separate SSD or other. As i stated i have multiple desktops and laptops that are dual boot with Windows and never had this issue. I was only referring to the fact that i didn’t feel it was necessary to remove the Windows SSD although you could as a precaution as @pebcak stated.

It was just a comment thinking out loud. I didn’t mean it to be anything other than a thought. I just find it baffling that some hardware causes so many issues compared to others. :man_shrugging:

I understand. I just wanted to make sure you were aware a lot of people don’t actually see it that way and will take it quite poorly even if you mean no harm and have good intentions. That’s just how a lot of people think. I’ve seen it a lot over the years managing folks, and since I see you post it A LOT, and thought to forward that if you didnt realize it.

Thanks… I didn’t mean it to come across that way. :innocent:

1 Like
**`sudo parted --list`**

Model: ATA SAMSUNG MZNLN512 (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.8MB  16.8MB               Microsoft reserved partition  msftres, no_automount
 2      17.8MB  512GB   512GB   ntfs         Basic data partition          msftdata

Model: INTEL SSDPEKNU010TZ (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name         Flags
 1      2097kB  1051MB  1049MB  fat32                     boot, esp
 2      1051MB  1024GB  1023GB  ext4         endeavouros


BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000,0001,0006,0003,0004
Boot0000* Windows Boot Manager  HD(1,GPT,78830e46-1bad-4fa9-a4a6-5ddb934bc911,0x800,0x100000)/File(\EFI\ubuntu\grubx64.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000033000100000010000000040000007fff0400
Boot0001* Diskette Drive        BBS(Floppy,Diskette Drive,0x0)0000424f
Boot0002* endeavouros   HD(1,GPT,571811b1-1992-b44f-bfac-811ba1db7ce7,0x1000,0x1f4000)/File(\EFI\endeavouros\grubx64.efi)
Boot0003* CD/DVD/CD-RW Drive    BBS(CDROM,CD/DVD/CD-RW Drive,0x0)0000424f
Boot0004  Onboard NIC   BBS(Network,IBA CL Slot 00FE v0114,0x0)0000424f
Boot0006* USB Storage Device    BBS(USB,Generic STORAGE DEVICE 1532,0x0)0000424f

*cat /etc/default/grub*

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT='nowatchdog nvme_load=YES loglevel=3'

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
1 Like


for better readability