Double click mouse issue

i am facing error with mouse, i clicked 1 time but worked 2 time . its only sometime, i tried with 2 mouse same issue.
for example - i use onboard app for typing when i can’t reach keyboard. and i clicked ( C ) but showing ( CC )
and its same in all apps. if i do (double click) then its like ( triple click )

  • Only with your mouse? Is your keyboard ok?
  • What is the connector USB or PS2?

yes keyboard working good
connector USB

I’ve experienced that before, because the switches inside the mouse went bad over time.

1 Like

Well, according to OP he has tried with 2 other mouses with the same issue. Might be the USB kernel driver faulty and detects or outputs 2 clicks for one.

Which DE?
E.g. Xfce has a mouse setting app with which you can change the time between two clicks, and another somewhat related mouse setting.

KDE plasma

its can be true

Hmm… looks like KDE has no such setting for the mouse, which is a bit of a surprise.
But I’m not a KDE user, so hopefully someone more familiar can help.


1 Like

That’s because KDE has defaulted to using libinput for a few years now; it used to use evdev, which has advanced mouse settings. You can get the old behavior back by doing the following:

Install the xf86-input-evdev package.

Create a drop-in file: /etc/X11/xorg.conf.d/20-mouse-settings.conf

(the file doesn’t need the specific name 20-mouse-settings.conf, but it’s a good name :grin:)

The file should have the following content:

Section "InputClass"
    Identifier "evdev-mouse"
    MatchIsPointer "yes"
    Driver "evdev"

Log out/log in for it to take effect (you may have to reboot, but I think logging out should work fine).

And now you will have advanced settings for the mouse:


Thanks! :+1:
That’s probably useful for the OP.

Thanks for that too! I also have an issue (unrelated to the topic) with my old mouse, your idea might help.


followed your all step , but i can’t found mouse - Advanced settings

Paste the output of:

cat /etc/X11/xorg.conf.d/20-mouse-settings.conf


pacman -Qi xf86-input-evdev

You did not create the file /etc/X11/xorg.conf.d/20-mouse-settings.conf as instructed.


but same

I have no idea why the cat command says that there is “No such file or directory,” but something is wrong there. :man_shrugging:

fixed this one. next step?

Log out, and log in.