Dolphin takes over 10 seconds to load a folder and consumes a lot of RAM

I’ve been using the Plasma 6 Wayland session in EndeavourOS on my ASUS ROG Strix GL-702VM laptop with an NVIDIA GPU since Plasma 6 was released. I haven’t had any issues until I did an update a couple of days ago. Now I’m getting some stuttering in Firefox and with a few apps. However, the most annoying issue I’m having right now is that it takes the Dolphin file manager over 10 seconds to initially load a folder when just a few days ago it was nearly instant.

I’ve run Dolphin from a terminal and I don’t get any warnings or other issues. However, when I open up the System Monitor, I notice that Dolphin is consuming a large amount of RAM, around 13 GiB, each time it runs.

Edit: I noticed that if I turn off Folder previews, Dolphin’s RAM consumption drops to 200 MB. However, it still takes over 10 seconds to load folders the first time.

1 Like

journal.pdf (30.9 KB)

I run Kde on my desktop with nvidia and have had no issues. Dolphin opens instantly and uses limited mb of ram.

Could be a few reasons, like badly working add-ons or AUR packages to name some.
Maybe command

systemd-analyze blame

might show some clue.

And journal right after you have started dolphin, something like

sudo journalctl --since "2 minutes ago"

BTW, are you using wayland or x11?

a finely tuned DE throttled by Baloo is what is smells like from here, but I’m just passing through.

1 Like

I’m using Wayland. The journal.pdf file that I attached after the first post was the result of a 20 minute journalctl where I ran Dolphin about 5 times within that 20 minutes.

I ceeated another user. Dolphin for the other user runs fine, so this problem is with my default user account. I removed my dolphinrc file, which didn’t help. I don’t know what’s going on…

About 200 MB sounds more like it. However, turning off previews shouldn’t be necessary for that amount. I have 7 folders opened in tabs at all times with Dolphin, and they all have previews for images and videos turned on.

It seems you may need to delete all files related to dolphin’s configs and start a fresh.

Look for:

dolphinrc file in .config
dolphin_dolphin_dolphin in .config/session
/dolphin folder in /local/share
/dolphin folder in .local/share/kxmlgui5/

You can just duplicate the files/folders, then delete the originals. Then log out and back in. Hopefully that fixes it for your default user account.

If possible, use another file manager to do this, like Krusader. Some files may get recreated almost immediately if you use Dolphin to do it.

Holy crap! Now it’s happening in Dolphin on my Surface Pro 8, except it takes over twice as long to open (about 20 seconds). That’s two machines with Plasma 6/EndeavourOS that are affected. I deleted all of the folders you mentioned, with the exception of .local/share/kxmlgui5/dolphin, which did not exist. It’s still happening. WTF??

Not gonna lie, the speed at which it opens for you (10 seconds) is the same speed it opens for me. And that is even when I set dolphin --daemon to autostart.

I thought it was normal tbh. I’m actually just trying to fix the preview issue lol.

Can you test if the preview issue still exists?

Dolphin has always been near instant when loading my home folder. Dolphin taking 10-20 seconds to load my home folder, even with previews on, is ridiculously slow.

I have all of the previews on, except Folder previews. Dolphin is still acting pretty wonky with Folder previews on, consuming tons of RAM whenever Dolphin’s window is in focus and right before closing.

One of the first things I tried was turning Baloo off. Dolphin still takes forever to load my home folder. I also tried turning off previews, disabling Google Drive integration (through overGrive), and deleting Dolphin’s configuration folders. None of that solves the problem.

BTW, what’s the purpose of running systemd-analyze blame?

I get that. That’s just not what I’m used to because my Dolphin launches with 7 folders already opened in tabs. But I get how it can be important that it launches instantly for other users.

By tons of RAM do you mean more than around 200 MB?

ruling things out means you are on the way to solving. some problems take a minute; sometimes days

I have 16GiB of RAM. Dolphin spikes to 3-13GiB when Folder previews is enabled.

Yeah, something is really wrong, and I unfortunately have no other ideas about how to fix it. I also have 16 GB of RAM coupled with 6 GB of VRAM. Never seen Dolphin take more than 300 MB.

That is, nothing other than switching to x11 and seeing if that makes a difference.

Yeah, I understand. Most of the time it’s something minor. I just wish I knew what changed a couple of days ago. Dolphin was working fine then. Also, Dolphin working fine for another user on the same system is a kick in the teeth! That usually means an add-on is causing the issue or the way my system is configured (away from default) is causing the issue.

1 Like

I found the issue by taking the new user account, slowing adding each of the add-ons I have for my main user account, then checking Dolphin after adding each add-on. When I changed my icon theme from the default “Breeze” theme to the “Flat Remix” theme that I use for my main user account (on both of my machines), Dolphin started behaving badly.

I quickly logged out of the new user account, logged in to my main user account, changed the icon theme to anything other than “Flat Remix,” then tried Dolphin. Dolphin opened instantly and my home folder loading instantly. I also turned Folder previews back on, and Dolphin is only using 145MiB of RAM!

So, something with the recent updates broke the Flat Remix icon theme from the KDE Store. I’ll try to install it directly from Github to see if that works. If not, I’ll report it to the developer and use another theme until it’s fixed.

BLUF: my favorite icon theme is not working well with Dolphin, causing all of my issues! Thanks for everyone’s help and putting up with my little freakout!

Edit: The Flat Remix theme(s) from Github are broken also…


Great that you found the culprit! :+1:

How did you install Flat Remix? From AUR, or downloading it from the KDE site?

I installed it from the KDE Store using the “Get New…” button under “Icons” in System Settings originally. After I realized that Flat Remix was causing my issues, I uninstalled the KDE Store version of it, then installed the Github version. After I verified that both versions caused the same issue, I uninstalled Flat Remix altogether.