Ditching rEFInd - returning to grub? Oops ... NOW IN TROUBLE

Goal: Uninstall rEFInd on my daily driver and return to simpler (happier) days of easily accessing multiple kernels via GRUB (as I can on other EOS setups around the house)…

What’s the most straightforward way of deactivating rEFInd and getting GRUB to find my various kernel choices? :thinking:

UPDATE: Well, seems by RTFM’ing I’ve managed to screw things up.
The rEFInd documentation says to simply:

# rm -r /boot/efi/EFI/refind
I then checked for any other steps that might have been relevant. None were.

Done. So then I reboot but now no matter which of my 6 kernel choices I select, I get this error:

error: symbol grub_is_shim_lock_enabled not found
(same error when loading the kernel and then system trying to load the initial ramdisk - i.e., two errors generated with no further progress.)

Oops. Well that’ll teach me about simply following the manual :roll_eyes:

I think it may have been necessary to also update grub and/or mkinit after removing rEFInd.

If you have a liveISO, try using chroot and running those.

sudo grub-mkconfig -o /boot/grub/grub.cfg

and

sudo mkinitcpio -P

Also, from a web search, this is what I get: how to switch from refind to grub

Search for grub in the arch wiki. Follow the install instructions. (They are pretty good, by my opinion.)

When all done and grub works, delete the refind files from the EFI partition and use “efibootmgr” to remove the boot entry from bios, if you feel pedantic

Looking at the rEFInd wiki, I actually don’t see the command you used. So, where did you see that? From the EndeavourOS forum?

Thanks for the follow up. Using balena-etcher on the Gemini ISO as I type this on my laptop.

Desktop still in criticial condition :frowning:

Found the uninstall instructions having googled “refind uninstall linux” and found the developer’s wiki, then going to the section “Uninstalling rEFInd” - seemed like a good bet at the time :wink:

https://rodsbooks.com/refind/installing.html#uninstalling

:sweat_smile:
Using the liveISO, go into that folder and tell me what you see.

cd /boot/efi/EFI
ls

It should show at least two folders.

Indeed … APPLE, boot, endeavourOS, Manjaro
No rEFInd anymore. Presumably that’s progress :laughing:
Now … on to chroot and follow up per above…

1 Like

Run the commands in the following order:
1.sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=GRUB
2. sudo grub-mkconfig -o /boot/grub/grub.cfg
3.sudo pacman -S linux
4.Re-run the second command.

I expect you to be running mkinitcpio.

You shouldn’t have issues with this unless your Appuh device decided to delete the efi boot entry for grub for no reason.

I have done these types of experiments with rEFInd on my host system a lot. Never had issues as yours.

Believe it or not, I cannot get my terminal on the ISO live drive to accept any root password, so I cannot accomplish much til I figure this basic stuff out :roll_eyes: sheeeesh…

Yes, I was just about to say that based on the manual, just reinstalling grub while rEFInd was active seemed like it wouldn’t have caused any issues, and would make it so that grub becomes default.

1 Like

Su ? Sudo works fine here. Don’t su on the live ISO, use sudo.

Even uninstalling rEFInd wouldn’t cause these issues. I am telling this with experience. Seems the OP has a quirky Appuh device.

1 Like

That’s weird. Are you following the steps here? https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/

Changed the article I linked to. The new one is better and more to the point.

How do ya like dem Appuhs :laughing:

2 Likes

Not so much , I prefer the blue Lakes of Intel , the Raging volcanoes of AMD and the icy haven of tux penguins.

“A tux a day, keeps the appuhs and Tim Cook away.”

1 Like

Opened terminal (konsole) in my “endeavouros” partition … but sudo grub-mkconfig ... reply is that the command not found

Seems you have grub uninstalled, run sudo pacman -S grub efibootmgr, then try

After command not found in response to above efforts, I successfully installed grub and efibootmgr … will retry above steps…

When running #1 above, I get error: failed to get canonical path of "/boot/efi" Never seen this particular error before. Learning as I go!

… FWIW, I do in fact have a /boot/efi directory in place populated as before I went down this rat (rabbit?) hole

Maybe retry using the steps from the EndeavourOS wiki?

https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/

It’s practically the same, but just as a sanity check. Meaning, do all the necessary steps from scratch and in order as outlined. Notice there is one for BIOS and one for UEFI.

Also, it’s possible you may have to redo your chroot steps as per the “path” error you got.

After this is all fixed, you can go back to that website then copy the steps (and/or explanations) to a file for any possible future issues. I have it in a file here, but I didn’t want to just give you what I have because it’s better for you to read and learn.

I’ve retraced the various steps above, tried them all including the links provided, but can’t get past #1

Perhaps my chroot step is misfiring. Specifically, what is involved in chroot (thought I knew!)

You may also need to unmount… Was just about to type this. Or reboot and retry from the chroot wiki, then on to the repairing grub wiki.

I am fully confident that this combo of wikis will fix it.

So, https://discovery.endeavouros.com/system-rescue/arch-chroot/2022/12/
followed by https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/

EDIT: just realised something. This whole time I’ve been assuming you are on EXT4. Is this correct, or is it BTRFS?

2 Likes