Distorted sound on host with new virtualbox 6.1.20-1

This morning a virtualbox update came in

upgraded virtualbox (6.1.18-2 -> 6.1.20-1)

This update finally fixes the dkms compile issue with binutils 2.36.1 but it introduces a strange bug. As soon as the guest OS is up an running, the sound on the host is distorted. I have tested with EndeavourOS, Linux Mint and Windows guest. And the sound on the host was either coming via youtube or via shortwave internet radio.

I have to change the audio driver for the host to ASLA-Audio to prevent the distortions. Before that it was PulseAudio by default and that does not work anymore.

grafik

Is somebody else experiencing this too?

1 Like

Host audio is working OK for me with linux-lqx 5.11.15+PipeWire 0.3.25+PulseEffects (Niceness) with a Windows 10 guest set to Pulseaudio.

This happens with existing VMs sometimes due to differences between sample rates of host / guest

To fix that you should try some voodoo magic:

  1. Change VM audio controller
  2. Boot see if it helps (most likely not)
  3. Change audio controller back to initial one
  4. Boot, hopefully that should fix

At least it worked for me when that happens

1 Like

I tried it all. Basically all combination of driver and controller. It does not help. With PulseAudio as driver the sound on guest AND host is distorted. This is really weird.

1 Like

I downgraded back to virtualbox 6.1.18-2 and the problem is gone. So this is clearly an issue with 6.1.20

2 Likes

Latest Whonix doesn’t work with 6.1.20 either, the VMs just insta-segfault, think I’ll be downgrading to 6.1.18 also.

1 Like

I have also the distorted sound issue with 6.1.22.1.

Same here. The issue persists. Workaround is to select the ALSA audiodriver (see the screenshot in my opening post)

1 Like

Thanks for the confirmation and pointing out the workaround!
I don’t know why I didn’t try that before. It works for me too!
Recently I have had my head in the …

image

Another workaround is to switch to Pipewire. I built my Distro ditching PulseAudio completely. A choice I made after I had very similar issue plus fact that using Pulse with custom AMD Ryzen Kernel resulted in audio recording coming out as if I was one of the Chip N Dale Chipmunks xD

Pulse out, PipeWire in no more vBox or Recording issues :wink:

I keep having distorted sound on all my linux distros, Debian- or Arch-based, in the past till today as host -vm in VirtualBox throughout the years. No VBox update ever changed that…

Could turning off all pulse-audio and replacing it with pipewire completely be a possible solution to that?

Just asking here. - Anyone?

:question:

I found a solution in the Arch-Wiki, that works with the latest installations of VirtualBox (6.1.34) and Arch-Linux-Xfce as a host.

Unfortunately, on Arch-Gnome it only improves the situation a little bit. It doesn’t resolve the two issues (distorted and / or laggy audio) completely.

Mind, this is not working at all for EOS- and Fedora-VBox-VMs in my case.

My suspicion: pipewire and/or gnome-shell as they are both not running under Xfce-desktop.

Perhaps someone can dig a little deeper?!

Apparently so.

1 Like

@jonathon - Thank you!

All pipewire pkgs were already installed and I replaced wireplumber (which was installed before) with pipewire-media-session.

2022-05-18_14-23

Now it’s finally working great on EOS-VM. Will see what to do on Fedora later on.

:beers:

2 Likes

Unfortunately, after changing lots of things, it isn’t as error-free in Fedora 36, as it is on Arch based systems. But I could achieve some improvements!

:rofl:

1 Like