Display Resolution 1920x1080

Hi,
I have a legion 5 r7 5800H.
I’ve installed endeavour os on vmware pro.

I’m trying to change display resolution

I’m unable to change the display resolution to 1920x1080 as the option is not available. I wonder why not, its the most common resolution used world wide
Hence I switched to xandr for fix. I found a article, in which the user specified about a script. which I ran for fixing the issue. But then every time I restart it goes back to original state.

I just want to know why 1920x1080 doesn’t exist, and how do I properly fix my display resolution

Make sure you have open-vm-tools installed and vmtoolsd.service enabled and started.

In that case, the vm should automatically resize to match the Window.

It’s installed and running. still same

sudo pacman -S open-vm-tools xf86-video-vmware xf86-input-vmmouse

sudo systemctl enable vmtoolsd.service vmware-vmblock-fuse.service

I ran them and rebooted still same.

systemctl status vmtoolsd.service

Are you running X or wayland?

What happens if you do sudo systemctl restart vmtoolsd

Idk what they are.

sudo systemctl restart vmtoolsd fixes. but I assume If I reboot it will go back to normal…

@dalto

There is a fix for that somewhere. Let me see if I can find it.

Here it is:

If you do things like this, it’s always a good idea to at least give a link to the script, so people know, what has been done/changed. Increases chances for successful support.

It’s there in the stackoverflow link

@tejas
I’m not having any issue with mine.

This fixes Thanks :+1:
But I still can’t copy past across host and guest. Shouldn’t it be fixed once vmware tools are installed…

I don’t have any issues either but there are a lot of variables including which version of vmware you are using, the hardware in the host(especially the gpu) and the host OS.

You need to ensure gtkmm3 is installed and then reboot.

It was preinstalled, still I reinstalled it. And yet the issue remains unchanged

Is that i3 you are using? Let me test it there.

Yes

It seems i3 requires special configuration here.

Add this to your i3 config at ~/.config/i3/config

exec --no-startup-id vmware-user-suid-wrapper

Then restart.