Display Power Manager Problem

After a “recent update”, my desktop display never powers down. I have the following settings in Power Manager:
All Buttons= do nothing
Sleep= suspend
Display Blank= 5 mins Sleep= 6 mins Off= 7 mins

It did work perfectly in the past, so something changed “somewhere”…
Any help much appreciated,

Dump of Neofetch:

                   ./sssso-                ------------------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: OptiPlex 9020 00 
             `-/ossssssssssssso/.          Kernel: 5.15.12-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 14 hours, 48 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 983 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.12 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Xfce 4.16 
  `:////ssssssssssssssssssssssssssso+++.   WM: Xfwm4 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Arc-Dark 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: Arc-Dark [GTK2], Arc-Darker [ 
   ./++++++++++++++++++++++++++++++/:.     Icons: Adwaita [GTK2], Arc-X-D [GTK3 
  `:::::::::::::::::::::::::------``       Terminal: xfce4-terminal 
                                           Terminal Font: Source Code Pro Mediu 
                                           CPU: Intel i5-4570 (4) @ 3.600GHz 
                                           GPU: Intel HD Graphics 
                                           Memory: 1543MiB / 15908MiB

EDIT: Added code tags.

An alternative way to present neofetch output is to use neofetch --stdout.

1 Like

While that is a neat option in neofetch (one I was unfamiliar with), the system info neofetch displays is almost always inadequate for any practical troubleshooting.

It’s much more productive to use inxi for this purpose:

inxi -Faz

Edited: thanks @keybreak, very cool!


btw, -Fxxxza is overkill :sweat_smile:

inxi -Fxxxz

is same as (-a have some additional options though)

inxi -Faz
1 Like

No argument there!

1 Like

here is output of inxi -Faz

[tommy@THOTH-OPTOPLEX-9020 ~]$ inxi -Faz
  Kernel: 5.15.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=6c2f45b8-5c10-415b-9e37-54e44473c70f rw quiet loglevel=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 9020 v: 00
    serial: <superuser required> Chassis: type: 15 serial: <superuser required>
  Mobo: Dell model: 00V62H v: A01 serial: <superuser required> BIOS: Dell
    v: A15 date: 11/08/2015
  Info: model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2783 high: 3386 min/max: 800/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3386 2: 1191 3: 3193
    4: 3364 bogomips: 25549
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412
    class-ID: 0300
  Display: x11 server: X.org compositor: xfwm4 v: 4.16.1 driver:
    loaded: intel unloaded: fbdev,modesetting,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    type: USB driver: rtl8192cu bus-ID: 3-11:5 chip-ID: 7392:7811
    class-ID: 0000 serial: <filter>
  IF: wlan0 state: up mac: <filter>
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    port: f060 bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 476.94 GiB used: 110.84 GiB (23.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: 30TT253X2-512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 0A0 scheme: MBR
  ID-1: / raw-size: 234.07 GiB size: 229.33 GiB (97.98%)
    used: 20.75 GiB (9.0%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  Alert: No swap data was found.
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 187 Uptime: 1d 1h 2m wakeups: 0 Memory: 15.54 GiB
  used: 1.68 GiB (10.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 993 pacman: 983 lib: 224 snap: 10 Shell: Bash
  v: 5.1.12 running-in: xfce4-terminal inxi: 3.3.11
[tommy@THOTH-OPTOPLEX-9020 ~]$

EDIT: Added code tags.
thank you…now I know how to use code tags…it’s different on different forums

1 Like