Display disconnects just before login screen

I have no idea what just happened.

It all started with some bizarre situation where my .bashrc was showing my aliases when ran through cat in the terminal, but they were not there when I opened the file in emacs. I had just moved them to a .bash_aliases file yesterday and removed them from .bashrc, though I could have still had an Emacs tab open with the original .bashrc file which may have created the conflict. I left everything open last night and had a few Emacs tabs open.

Either way, I rebooted the system, selected my kernel (I installed lts to get i3-gaps to work) and it started booting but just before the login screen would normally pop up, my display says “no source” and goes blank. The device is still running at this point. I’ve rebooted a couple times since this happened with the same effect.

Anyone have an idea of what could have caused this and how I can fix it? My newb brain can’t wrap my head around why a conflict with .bashrc could cause what seems to be display issues.

I connected my other monitor and it works fine. I truly have no idea what the hell happened.

Can anyone clue me in on why my graphics interface would work with my original monitor before the kernel starts up but just stop working afterwards and then work fine with a different monitor? I’m guessing the driver got corrupted somehow, maybe?

Honestly I am more intrigued than anything at this point. What a weird little glitch. I feel like this could be a good experience to learn a bit more about hardware.

Perhaps your HDMI cable is defect? Without any hardware info it’s hard to guess what is going on.

Since you use i3 from what I gather, run arandr, and check that both if your monitors are active?

Also post output of xrandr when both monitors connected.

We dont know anything about your system. Is this a laptop? Graphics card Nvidia? Which driver? See link I posted above.

That’s fair, I should have given more information. Just got home from work, I’ll post the logs in an hour or so.

As for the HDMI, I would assume that if it was bad it wouldn’t just stop working after the Grub menu it would just not work at all, or cut out sporadically, right? Plus, it seems to be working just fine with the other monitor. I should mention though that it is an HDMI to DVI cord. Both of the monitors are second hand from Goodwill, the PC is second hand as well and older.

Here are the specs for the PC. It says that the graphics are Intel Integrated Graphics, which doesn’t seem like a whole lot of useful information. The only upgrades I found when I opened it up was a RAM upgrade, but I’ll open it back up this evening and see if a graphics card was added.

Sorry I didn’t get back to this yesterday. Work has been whooping my ass. Now that I have done it, this seems ridiculous, but I had a tough time figuring out the logs. Like I said, been burnt out.

But also, the xrandr is just the current monitor. I have no way of obtaining the output from the one that is acting weird. I only have one cable. I’m working on trying to set up ssh through my phone to the computer, but something isn’t working right.

Hardware
Boot log
xrandr

your links don’t work… it will be difficult to troubleshoot if you can’t connect two monitors. If you can somehow open a terminal then connect to the other monitor and type xrandr then press enter. Then switch back to your working monitor and post directly the output here in quotes for code. No need to create an extra link.

The forum log tool is pretty simple, its just opening the welcome app, the select logs for troubleshoot, then make selection, which creates a link that you can post here for hardware specifics and journal logs depending on the problem.

Also some more infos on the monitors, model, resolution etc. may help.

don’t burn out, take it easy :wink: it’s almost Christmas break.

Edit: I guess you could also just post output of inxi -Fxxc0z, but make sure to format text in quotes

Hardware and xrandr logs don’t show anything. . .

From the boot log

Dec 14 18:55:36 hp-stream kernel: i915 0000:00:02.0: [drm] HDMI-A-1: EDID is invalid:
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  00 ff ff ff ff ff ff 00 5a 63 1d e5 01 01 01 01
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  03 10 01 03 80 2b 1b 78 2e cf e5 a3 5a 49 a0 24
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  00 50 54 bf ef 80 b3 0f 81 80 81 40 71 4f 31 0a
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  01 01 01 01 01 01 21 39 90 30 62 1a 27 40 68 b0
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  36 00 b1 0f 11 00 00 1c 00 00 00 ff 00 51 36 59
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  30 36 30 33 30 33 37 39 38 0a 00 00 00 fd 00 32
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  4b 1e 52 11 00 0a 20 20 20 20 20 20 00 00 00 fc
Dec 14 18:55:36 hp-stream kernel:         [00] BAD  00 56 58 32 30 32 35 77 6d 0a 20 20 20 20 00 fd
Dec 14 18:55:36 hp-stream kernel: i915 0000:00:02.0: [drm] Cannot find any crtc or sizes

Then again

Dec 14 18:55:36 hp-stream systemd-udevd[216]: card0-HDMI-A-2: Process '/usr/lib/snapd/snap-device-helper add snap_rpi-imager_rpi-imager /devices/pci0000:00/0000:00:02.0/drm/card0/card0-HDMI-A-2 0:0' failed with exit code 1.
Dec 14 18:55:36 hp-stream kernel: i915 0000:00:02.0: [drm] Cannot find any crtc or sizes

And Again

Dec 14 18:55:36 hp-stream kernel: i915 0000:00:02.0: [drm] Cannot find any crtc or sizes

I see two different HDMI? HDMI A-1 and HDMI A-2 Do you have more than one monitor hooked up?

The second link seemed to be working and I fixed the last one. I typed a 0 instead of an O in the URL. The first link I got a similar result without the eos-sendlog command, but it worked without it. I had assumed that the --no-host flag in that article was related to the log tool. I’ll re-run it without that flag and grab the link.

I should be able to get the output via ssh, right? I just got home from work. I’ll fix the inxi link and start working on getting ssh to work from some other device.

I don’t. I have two separate monitors and plan on setting up extended display, but up until this happened the other monitor I am using now had never been connected.

I saw this as well and dismissed it based on the pi-imager comment. I recently installed that from Snap, which I installed specifically for that app. Could something there have caused the issue?

I fixed the xrandr link and am about to fix the hardware link right now. The article shared above included that --nohost flag, which seems to not be needed or even exist with the tool.

The syntax is --no-host

Yeah, I just realized that. It’s fixed now.

Thank you all for your patience with my newness to all of this. This community is rad.

I got ssh working and the output of xrandr with the malfunctioning monitor is

Can't open display

Sorry got a bit confused. Which monitor is which? Is DP1 the one that works or the one that doesn’t? And what about HDM1?

Screen 0: minimum 8 x 8, current 1440 x 900, maximum 32767 x 32767
DP1 disconnected primary (normal left inverted right x axis y axis)
HDMI1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 410mm x 260mm
   1440x900      59.89*+  74.98  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Can you reboot and tty? then do xrandr?

What is the make and model of the monitor? And can you boot into it using the live iso via xfce?

What is using the tty to ssh into something because the monitor isn’t working?

I tried that already, and got the same result as booting into the gui

Viewsonic VS10859

I’m could try. What would I do after I boot?

I’m not sure I understand your question.

I am just wondering whether it is a setting in your i3 or it’s a missing driver in general. If you can boot into live iso you should be able to use xrandr. I just want to see if the monitor can be recognized, then we could modify your i3wm script to autorecognize your screen on startup. We can use the information from xrandr and later prepare a script that we can autostart.

Just an idea, don’t know if that would work.

1 Like