Difficulties booting into live image with RX 6700XT

I managed to get my hands on an AMD RX 6700XT graphics card for a very affordable price, and I got an ASROCK X570 Taichi motherboard with it. Not a big fan of ASROCK, but X570 seems to work well with Linux.

However, I am having difficulties booting into a live image to install EndeavourOS on this new computer. The boot process just hangs at

:: Triggering uevents...

I remembered from some time ago that this was common with AMD cards, and that setting nomodeset Kernel parameter fixes this. Not in my case, I do get a bit further with boot, but the X server won’t start.

I’m too sleepy at the moment to think clearly, having messed around with this for several hours. If you have any suggestions, I’d be very grateful.

1 Like

AMD flawlessness with Linux is a little bit overrated :grimacing:

P.S. DDGoogling haven’t gave much info


Have you disabled all the Secure / Fast boot crap on your new motherboard? :upside_down_face:

https://bugs.archlinux.org/task/46745

:thinking:


Have you blacklisted nouveau?
Are you on LTS Kernel?


Check this out:

You need linux-firmware-git from the AUR and mesa-git from the AUR for the screen glitches you get after you have a working graphics cards from installing the linux-firmware-git package.

https://bbs.archlinux.org/viewtopic.php?pid=1968315#p1968315

1 Like

None of that helped. I even made a vanilla Arch install and installed linux-firmware-git and mesa-git from the AUR. I just can’t startx. I’ll figure out how to get a log file and post it here.

1 Like

:man_shrugging:

doesn’t @Elloquin have an RX6700XT too?

3 Likes

I do but I am running to work be back a lil later. The issue is the iso image lacks the latest firmware which came in may I believe. (April iso) @joekamprad could they try a dev iso?

1 Like

Hmmm…wonder what firmware it is then, since

Arch + git should be latest?

What I ended up doing was (same card same mobo) was too install a freshly burned arch iso and that would boot. A short time later a dev iso came out for testing EndeavourOS and that booted as well.

2 Likes

Yes, Arch ISO boots to TTY, and Arch installs fine, but I can’t start a graphical session. Just TTY.

There is no hurry, as long as we get this solved eventuallyTM. I’m at work now, too.

I’ll try the dev EOS ISO.

1 Like

Not enough Taichi :wink:

2 Likes

Some progress, I managed to boot the latest dev EOS image, X session is started (Good Lord, I was never in my life so glad to see so much purple! :purple_heart: ). So it works, the new computer is not just an overpriced potato. Excellent!

I can’t install EndeavourOS from this live image, unfortunately, as its calamares is broken (missing file /usr/share/calamares∕settings.conf_online).

Nevertheless, that is good news, as it means everything can work, there is no hardware issue, and I simply botched my vanilla Arch install (though I can’t say for sure where, since I’ve done this a dozen times before and I didn’t do anything different).

1 Like

are you using the latest dev iso?
if so there should be a starter on the bottom panel to start calamares

edit: make that 2 launchers @Kresimir
1 to start offline install, and one to start online install

4 Likes

Just installed EndeavourOS, with KDE, everything seems to work fine. Marking your post as the solution, because finding that calamares button on a high DPI screen was the most difficult thing of the whole process :rofl:

frog_sunglasses_72

4 Likes

Alrighty, glad it worked out!
Enjoy your new beast of a system!

1 Like

What have you got that RX6700 XT paired up to? :rocketa_purple:

Edit: Ryzen 5950? :laughing:

1 Like

Ryzen 9 5900X

I was thinking of buying a new PC for ages now, but I had a pretty decent desktop (with really crappy graphics), so I postponed it and postponed it for a few years. Then the hardware prices skyrocketed and I gave up.

But then I got a really great deal for this configuration and I just bought it on a whim. It cost me just under $2000 (with a PSU and a Samsung nvme drive).

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.