Dependency failures causing failed boot

I will type just type out the error lines at the bottom and add a photo after I provide a short description. I am using (more like trying to use…) Endeavour on a 2009 Macbook Pro. I am a Debian and Suse user but Endeavour is best for this computer because of Nvidia driver needs. I know Debian has them out of the box but I wanted an Arch-based distro on one of my computers. Anyway, this has been a constant issue, the install has gone well for the most part (all 12 times), but once I reboot, this is generally what I have gotten. There have been a couple of times that I have gotten after an update. I finally swapped the internal hard drive and the install went great and even rebooted several times successfully with no issues…then I thought I’d get kinky with it and install the deepin DE :man_facepalming:…now it is doing it again. This is immediately after I rebooted it after the DE install. The other times it would try to go into Emergency mode with root login. I have used Linux (Debian-based) for many years, but this is the first time I have tried to do it on a Macbook, windows PCs go great usually and when they have issues I can usually resolve them. The only thing I can think of is that when I first noticed this issue, I upgraded the ram in the Macbook. During the many installs of Endevour, I tried Debian once and the install went great until I did the first reboot and there was no error but on boot up, I just got a black screen with a blinking cursor.

Starting version 248-1-arch
/dev/sda2: recovering journal (the first time it did this i turned it off with power button…moving on)
/dev/sda2: clean, 484850/19521536 files, 7020907/78064856 blocks
[ TIME ] Timed out waiting for device /dev/disk/by-uuid/5D97-20EE.
[DEPEND] Dependency failed for File System Check on /dev/disk/by-uuid/5D97-20EE.
[DEPEND] Dependency failed for /boot/efi.
[DEPEND] Dependency failed for Local File System.
[ 383.177131] EXT4-fs error (device sda2): ext4_journal_check_start:83: comm systemd-tmpfile: Detected aborted journal
[ 383.259366] EXT4-fs (sda2): Remounting filesystem read-only
_ (<—then this just blinks)

Hello @caquinn
Maybe read up here first.,2_(early-mid_2009)

Okay that does hit on the issue but isn’t rEFIt for dual-boot? I do not have MacOS on here at all. Like all of my computers, it is dedicated Linux…well trying to at least. I am going to look more into this. Thank you for the quick response.

Okay, after reading it, I see that a third partition (/root) is required for Arch-only. That might just solve my issue. Thank you very much. I will try it out and update this with my results.

I’m not sure what partitioning you were doing? Is this Macbook UEFI Bios?

It looks like an issue with the disk. Try booting off the ISO, running an fsck on it and then check the smart status.

If you want more information on how to do that, just let us know.