Dell xps 9720

Has anyone succeeded installing EOS on dell xps 9720?

On my side the installation process is painfully slow (same with pure arch), and the OS is completely unusable after the install. I have the mouse and say I can open the settings, but I can’t click on stuff inside. Or I can open the terminal but again, I have very limited control over it it terms of clicking stuff. The screen resolution has only one option (I forgot the exact numbers) and it things where very small. And when I shut down, it gets stuck forever. I have to push the button for 7 sec to force shut down. Do you think it’s my unit having issues? It’s a brand new laptop.

I would try to install another distribution and see what happens…

I had issues with Fedora too. Only PopOS worked very well.

So maybe the kernel, which is more recent in Fedora and EOS? In Pop os is older.

Since you’ve mentioned Fedora and Pop - i’m pretty sure you install Gnome which starts on Wayland…Try to install KDE and see how it goes.

I’ve had some extreme problems with Gnome under Wayland on Fedora on my DELL Precision

I installed Fedora KDE. I haven’t tried the GNOME version. With EOS, I did KDE as well.

1 Like

So do you think this is a temporary issue with the new kernels? How can I make sure that’s the case?

Hardware info, logs could give some more info to someone who might get some ideas:

Install the LTS kernel version closest to the kernel provided with POP_Os!

I have EOS installed on the Dell XPS13 9350. Never had an issue with it.

Edit: Could be a problem with the live usb. How did you create it. On Windows best to use etcher.

I’ve had dozens of distros on my Dell 7548 without issue.

Edit: that’s a way nicer and newer computer. I doubt my experience was relevant.

No issue so far on my Dell 7400, i created bootable iso with gnome-disk-utility

1 Like

I created the ISO with gnome util tool on my other EOS machine. I tried the LTS kernel. Even though I did not have the shut down issue, the rest of the issues mentioned in the original post were still + screen tearing, which did not get resolved after installing Nvidia drivers.

There was no way to change the display resolution from the KDE setting as the settings menu was not functional at all.

I just ended up reinstalling PopOS and I’m pretty happy with it. Probably I’ll keep it for now.

I use popsicle on EndeavourOS for creating the live usb.There shouldn’t be any problem installing on that laptop. It has hybrid graphics so you should try install with Nvidia. If you use the default entry it should install the Nouveau open source drivers for the Nvidia card. You still would have to use one of the methods for switching graphics cards such as optimus-manager.

With a lot of fiddling I’m sure you’d get the thing working swell on EOS too.

If you’re not inclined to invest the time in this, however, before quitting the Arch universe completely, give Manjaro a try too. They have a video driver utility which might work for you out of the box. And maybe come back to Endeavour in a year or so and check if things have been sorted out by themselves. Given the speed this OS rolls, things usually sort themselves out in a year’s time.

I gave another try, this time with Nvidia mode and I have chosen the offline option. Fortunately it worked. Now, I don’t know if I should manually install KDE (not that I know how to do it). But I’m afraid it will mess up the system again.

What did you do differently this time other than use nvidia option? Offline installs xfce desktop. Did you use the new ISO just put out?

Edit: Is the laptop working properly now? Resolution correct? Shuts down and reboots properly? Not slow and freezing up?

What does it show for this command. Provide the link it gives.

inxi -Faz | eos-sendlog

It worked both with and without NVIDIA option. The only thing was that I had to choose the offline installation. For example, online xfce did not work either. After doing online xfce, I got the shut down issue back which I did not have with offline xfce + update once the machine boots up.

The process of the installation was very slow tho. The progress bar was hanging and I had to move the installation window to get its content updated (both with online and offline installation methods). the ISO I used was freshly downloaded 2 days ago.

The only problem was that I still got more issues in terms of the NVIDIA drivers. First, all seemed fine until I attempted to install the cuda and cudnn and use the NVIDIA container toolkit. Since the issues were piling up and at the end I could not make KDE work (not a fan of xfce), I decided to give manjaro a try. It worked out of the box. The NVIDIA drivers along with cuda and cudnn works perfectly, and no issues with KDE, no shut down issue when I have to do hard shut down manually.

I still use EOS on my stationary Intel cpu PC that runs GeForce GTX 1070 Ti with nvidia/cuda/cudnn/etc and it basically worked out of the box. I think this is a hardware compatibility issue with NVIDIA based laptops related to vanilla arch in general. I had similar issues with my ASUS ROG 14. On ROG, there was also a WiFi speed issue. The system was using only about 5% of the speed on EOS. On Ubuntu and Fedora, the download was crushing after a second or two.

PS: I returned the 17 inch Dell xps and got the 15 inch version (9520), but the issues I have faced were not vastly different. That said, 15 inch had less issues with different distros in general.