Deepin 20 Arrived

Sorry if i misunderstood you. If you have already installed another desktop you just switch to it before logging in. Top right corner as @dalto has pointed out.

Yup, got it (how much more hidden could that dang thing have been?)…and it even works! Only…because of today’s developments, there is still no panel and dock. But at least now I can keep an eye on it for fixes while not having to depend on it as my one and only DE. Thanks!

I have had Deepin installed a number of different times. The first version 15 worked well. This new version 20 is not my favorite. I have had issues getting it to work on my hardware and now the Dock isn’t loading. I had given up on it for now as i use xfce, cinnamon and plasma.

Yup, exactly what I’m doing and for the same reason. I chose xfce because of its “native” status with EndeavourOS but I actually prefer KDE (and have it with Manjaro and Kubuntu in installs on other laptops).

I know that the right-side control panel of Deepin 15 was widely criticized (Tom of Switched to Linux said that it was initially very cool but in day-to-day use very annoying) but I had no problem with it and actually enjoyed something unique when so many DEs are just slight variations on the same basic idea. (I’m aware of Budgie…and used it briefly with Ubuntu…but when I saw that the Raven panel contained only a calendar and some audio controls, I thought…“Really? That’s it?”)

I have DDE Ubuntu installed in virtualbox and i like it. It is a remix & i do get some errors popping up but i submit them so hopefully somethings get fixed.

someone using deepin and can tell something on close to tray is working or not? may there is a package needed or something i can not find any setting to this…


I try to reproduce this and i see that qbittorrent disappear if you close it to tray…

I can confirm the same thing you are seeing. Anything that is minimized to the tray on deepin just disappears.

1 Like

My experience with Deepin on EndeavourOS is that on my AMD RX590 i have to set the window effect on right away or the system will freeze the whole computer. Once set it works fine and i am currently running it on virtualbox. Htop still doesn’t work unless you run it from the terminal. Still haven’t figured out how to fix that. The only other issue is qbittorrent doesn’t show minimized in the tray. Not sure where it is if it’s there?

All minimized apps are there and do not dissappear as shown.

More:

Edit: I can also report that any apps that come preinstalled on deepin only minimize once and then if you open them again and try to minimize them you have to click on the docked icon in order to minimize them. The minimize (-) icon doesn’t do anything after the first time. So subsequent attempts you have to click on the docked icon. Any apps that i have installed after on my own i can minimize and open multiple times with no issue. I have tried every single app that comes installed and that’s the way it’s working on my system.

Install gnome-terminal :exploding_head:

1 Like

Do you uninstall deepin terminal?

issue is more that if you close to tray is not working, minimizing should show an icon on the panel…

Close to tray?

qbittorrent have this option and most chat apps too… if you close this apps they still running but you can not reopen them from tray because they do not show up there…

No, you don’t need to remove any other terminals. The issue is when a .desktop file has Terminal=True set it is being opened in gnome-terminal. If you don’t have it installed it fails. That is probably configurable somewhere, but I have not looked for where.

1 Like

Okay …yes. I have qbittorrent installed and i mention that.

Edit: Another issue is the Mutitasking view doesn’t work also. Does nothing when i click on it…

1 Like

Yes, that is also broken for me currently. It was working a few days ago.

It seems like deepin is just not in a stable state right now. Every time something is fixed, something else breaks. I guess it is the nature of beta software.

Yes, I also think it was working before but not now.

Edit: I have installed the Arch version downloaded from Deepin off of sourceforge and installed it in virtualbox. Same issues really but the Multitasking works.

Deepin 20 is awesome! But it had some bugs…

How’s it going with bugs?
Does anyone have trouble running flatpaks and snaps?

Welcome Aboard! @Telmo1241

I recently spent a week revisiting deepin to see how things were coming along. It should still be considered very much a beta, more like a working alpha release candidate. As for flatpacks and snaps deepin has a hard enough time keeping the desktop environment stable so any additions to it are subject to the very same limitation. There was an update yesterday that broke the notifications panel visually. In a day or two that will be fixed and another issue will pop up. It is however actively being developed so time will tell.

1 Like