Darktable arifacts in thumbnails


I have a weird problem with darktable. It started to show green squares in the lighttable thumbnails:


These green squares are moving for the first 1-2 seconds after start. Then they are fixed but they are moving again when I hover the mouse over the thumbnails. I have opened an issue with darktable on github which also contains a short video showing that effect:

The github issue is closed in the meantime because it does not seem to be an DT issue. But rather it has to do with my system. Something has changed over the last couple of weeks and I do not know what.

I downgraded gtk3 and gtk4 and linux-firmware but that did not help. I failed to downgrade the xserver. Somehow I always end up with a frozen lightdm login when I tried that.

Does anybody have an idea how I can debug this issue?


System:    Kernel: 5.15.2-arch1-1 x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: EndeavourOS
Machine:   Type: Desktop System: Gigabyte product: X570 AORUS ULTRA v: -CF serial: <filter>
           Mobo: Gigabyte model: X570 AORUS ULTRA serial: <filter> UEFI: American Megatrends LLC. v: F35d date: 10/13/2021
CPU:       Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache: L2: 4 MiB
           Speed: 2196 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2196 2: 2124 3: 2195 4: 2195 5: 2189 6: 2196 7: 2331
           8: 2192 9: 2194 10: 2108 11: 2195 12: 2195 13: 2193 14: 2196 15: 3960 16: 2180
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu
           v: kernel
           Display: x11 server: X.Org driver: loaded: modesetting resolution: 2560x1440~60Hz
           OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.42.0 5.15.2-arch1-1 LLVM 13.0.0) v: 4.6 Mesa 21.2.5

Could be the graphics driver. Try with an LTS kernel.

I did this. I tried LTS and linux-zen. Also, I booted my PC with a persistent live USB installation (created with ALMA a long while ago). This installation still has linux 5.14.12.arch1-1 and linux-lts 5.10.73-1 and it shows the same issue.

Which version did you install?
What’s the output of yay -Qs darktable?

I installed latest darktable 3.6.1, but downgrading to 3.4 does not help either. And this is really weird because I am a frequent DT user and I never had this issue before.

In the meantime I have booted into a live fedora fc34 system and checked DT 3.6.1 on fedora. It does not have the issue. That tells me that (1) I do not have a hardware or BIOS issue and (2) this is not an issue with darktable but with some other package.

And I have removed all thumbs from $HOME/.cache/darktable and this does not help either

And the issue occurs also with a new user on the PC.

I found the root cause. This update of xorg-server and xorg-server-common caused the issue:

[2021-11-10T06:54:32+0100] [ALPM] upgraded xorg-server (1.20.13-3 -> 21.1.1-2)
[2021-11-10T06:54:31+0100] [ALPM] upgraded xorg-server-common (1.20.13-3 -> 21.1.1-2)

Downgrading these two packages is tricky. With their installation all the relevant xf86-video-* packages got removed. They need to be reinstalled. The EndeavourOS live USB image from 2021-08-27 helped me to identify the missing packages.

I went to the Arch Archive https://archive.archlinux.org/repos/2021/11/09/extra/os/x86_64/
and downloaded

xf86-video-ati-1 19.1.0-2-x86_64.pkg.tar.zst
xf86-video-intel-1 2.99.917+916+g31486f40-1-x86_64.pkg.tar.zst

Installing those packages is solving the issue. I have updated my /etc/pacman.conf to igonre those packages:

IgnorePkg = xorg-server xorg-server-common xf86-input-vmmouse xf86-video-amdgpu xf86-video-ati xf86-video-fbdev xf86-video-intel xf86-video-vesa xf86-video-vmware xf86-input-libinput

And now I am wondering why nobody else has reported an issue with he new xorg-server 21.1.1.

1 Like

Congratulations, you have won the lottery to be first! :1st_place_medal: :partying_face:

1 Like