CUPS not connecting to wireless printer

New to Arch. All non-arch distros install printer and it works. Thought I would try forum before I ditch Arch because Endeavor is VERY nice. Am new to Linux, spent three hours in CUPS with Manjaro doing everything I could find on internet, no luck, Endeavor doing same thing. CUPS finds printer, install good driver then says cannot locate. Brother DCP-L2540DW. Have tried all different options to connect.

Welcome here!

Just to make sure, please have a look at https://wiki.archlinux.org/title/CUPS

Did you install print support during eOS install?

Did you find any drivers for your printer or was it missing? Sometimes they require additional proprietary drivers, some of which can be found in the AUR if you are lucky.

Edit: seems your lucky day, found a couple of packages in the AUR

https://aur.archlinux.org/packages/?O=0&SeB=nd&K=Brother+DCP-L2540DW&outdated=&SB=n&SO=a&PP=50&do_Search=Go

Install via yay -S packagename

And make sure to read about AUR

I had a similar problem with my Brother printer the other day (at least the way you describe it) and the solution that worked for me is described in the archwiki/CUPS/Troubleshooting article under ’ Unable to locate printer’ (https://wiki.archlinux.org/title/CUPS/Troubleshooting#Unable_to_locate_printer); in short: tinkering with the Avahi Host name resolution (https://wiki.archlinux.org/title/Avahi#Hostname_resolution).

Don’t forget to restart your PC (or to restart the relevant systemd services).

EDIT: Also make sure that you set the correct .ppd file for your printer driver when setting up the printer in CUPS. For some reason it didn’t automatically find the .ppd file for my printer installed by the AUR package. For me the .ppd file is located under /opt/brother/Printers/<Printer>/cupswrapper. If necessary, try manually providing it to CUPS.

1 Like

Probably because these are proprietary drivers, they may be provided by brother as .deb or .rpm and distros like ubuntu may have implemented those to be noob friendly. However, in arch it will then either have to be installed via aur or you have to convert the .deb package if nobody has done so yet. Just fyi…

Did you have to install the driver via AUR, which package did you choose?

I installed the driver via the AUR and on all my other EnOS devices it usually worked out of the box. Don’t know what got messed up here, but I probably messed up something. But it was easy enough to fix by just manually selecting the .ppd file to CUPS instead of automatically letting it find it (which it did btw, but somehow after finishing the setup, it forgot about it). So this is probably a me specific problem and not so relevant for the question at hand.

I had the same problem, but I discovered how to solve it by following another wiki.
Install the sane-airscan package and (optionally) ipp-usb. These packages solved my problem with my wireless Epson L3150 and might help with other printers too.