Printer Brother HL-L2350DW may not be connected

That’s the message I get when I try to print. I tried setting up a printer via the GUI at EOS installation and got the message Printer Brother_HL-L2369L may not be connected. I did some searching and discovered Brother only provides driver packages deb and rpm. Did some more searching and someone used a program called paru to install so I installed paru and tried adding a printer that way. It appeared to successfully add the Brother printer but I get the same result when I try to print. Someone recommended creating a ppd file but I got lost in that process. I couldn’t figure out how to create a ppd file from Brother’s website. Does anyone have any ideas? I do a number of Google searches before I bother you guys. I hope someone can help. I’ve got everything set up the way I want in EOS except for printing.

OOP. I meant to say Brother HL_L2350DW. That’s the printer I’m unable to get installed.

You can edit your post and its title. :wink:

Providing generalities like this mean people have to guess or ask for clarification, and that’s not massively efficient. Instead, please provide the specific things that you tried (e.g. which package you installed from the AUR).

I didn’t install a package from AUR unless you mean whatever was installed by the GUI when I installed EOS. Same with paru. I specified Brother_HL-L2350DW and it found and installed a driver. Where it got it from or what the package is called I don’t know other than it’s called Brother_HL-L2350DW. Pardon my ineptitude. I’ve been using Linux for a few years (Mint) but I’m just now trying an Arch derivative. I’ve always been able to solve problems on my own or find a solution on the net before. It’s just recently that I’ve resorted to asking questions in forums and I’m not well acquainted with what is needed for people to help. I’ll tell you what I can. I’m running a Dell Inspiron 15" laptop, with the most recent version of EOS. I believe it’s 6.1 - with the i3 window manager. The printer I’m trying to install I mentioned before. And I don’t know what packages were installed other than they were done by the GUI and paru. Both of them only labeled the package as Brother_HL-L2350DW. I’d appreciate a little patience. I’m new at this forum format. I’ll certainly provide any info that would be helpful. The “Not connected?” Printer Brother_HL-L2350DW may not be connected message comes up in a dialog box at the upper right of the screen a few minutes after printing is attempted.

That goes both ways.

This will be worth finding out - noone here can guess that.

I picked the closest driver I could find. Copied this from CUPS:
Driver: Brother HL-2250DN - CUPS+Gutenprint v5.3.4 (grayscale, 2-sided printing)
2350 was not listed. Is that the problem? If so, am I stuck and no driver exists? There are deb and rpm packages at the Brother website.

There are several driver packages in AUR:

❯ yay brother 236 
3 aur/brother-hll2360dw-cups-bin 3.2.0-1 (+0 0.00) 
    CUPS wrapper for Brother HL-L2360D series printers
2 aur/brother-hll2360dw-lpr-bin 3.2.0-1 (+0 0.00) 
    LPR driver for Brother HL-L2360D series printers
1 aur/brother-hll2360d 3.2.0_1-1 (+10 0.03) 
    Brother LPR and CUPS driver for HL-L2360DN, HL-L2360DW, HL-L2365DW

After installation, there should be new drivers available for selection.

BTW: I have the HL-L2340D and got it working this way. I used socket://{printer_ip}:9100


1 Like

You might also find the answer I have given to the following problem helpful:

1 Like

I do use exactly this printer without the need to install any driver :wink:
This model work driverless if connected over wifi.
The only thing you need to set up is a workaround to get local DNS-Resolution enabled as @TheRaOct mentioned already ;):

Edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns:

Restart avahi-daemon and NetworkManager after this, or reboot the machine:

sudo systemctl restart avahi-daemon NetworkManager

If chosen to install brother-hll2350dw from the AUR you will be also able to use the printer by using URI as @anon68400099 mentioned before for the older model:

Need you to know the IP of your printer … over the IP you can also reach the webinterface of the printers PrintServer (on the printer itself) from a web-browser.

And for driver selection you need to find the driver named for Cups :
Others will not work. (as this is the one you installed before)


Thanks for all the suggestions. I’ll try everything. So far I tried yay brother 235 (there was a typo earlier.Meant to say Brother_HL-L2350DW). At any rate I ran yay brother 235 and it seemed like I was able to install the driver for Brother_HL-L2350DW. Tried adding the printer in the CUPS interface but I got the same message “Printer may not be connected”. So I tried deleting the printer then adding it back. This time I got lpr: Error - No default destination. I tried deleting and re adding the printer again and still got lpr: Error - No default destination. Tried rebooting but that didn’t help. Tried choosing the driverless option but got the same result. I’ll try the other suggestions. The CUPS interface seems to indicate that the printer was added and is ready but I’m still getting that error lpr: Error - No default destination. Seems to indicate the printer was not in fact added.

You may need to remove the stuff you installed and make sure cups and avahi are running fine:
systemctl status avahi-daemon
systemctl status cups.service

sudo pacman -S --needed cups cups-filters cups-pdf system-config-printer

indicates also you may choose the wrong URI / protocol on adding your printer … and you do not say at all if your printer is connected via wifi or USB or network cable… nor do you specify exactly the way you add the printer… or if you removed non-working added queues ?
Also, the printer needs to be powered on to find it over the network, depending on how the printer is set up it will go in sleep mode after a period of time on its own also if this happens before you add the printer it can not be setup locally on the client.

AUR has this driver: brother-hll2350dw

EndeavourOS has no versions as it is basically Archlinux where updates are rolling released.

And as i do see users mention they are using version 6.1 of EndeavourOS i would like to know where this info comes from?

1 Like

It’s working now!!! After I edited nsswitch.conf, deleted the printer I had, set the printer as default then rebooted, the printer works. How on earth did you know to edit the nsswitch.conf file?
The local DNS resoltion is not enabled per default. (for security reason)

1 Like

I forgot to say “thanks”. How on earth someone knew to edit the /etc/nsswitch.conf file I’ll probably never know. Again, Thanks!

He knows cause he’s the doctor. :mask:

I found that out during the last printer colonic irrigation