Create new profile in konsole

I’m trying to create a new profile in konsole, but it always vanishes after restarting the app.

Unfortunately, this is an old known bug.

this is how you can solve it, go to the folder:


in your home folder, then create a file with the name:


and paste the following content:


replace profile_name with a name of your choice for the profile. the names for the file and the name in the file should be the same.


Yes it does unless you create the new profile and then switch to it. I currently have the default profile and the one i created. As soon as i switch to the default then this one will disappear.

Edit: Didn’t know that it is a bug and if so why haven’t they fixed it?

Bug reports have often been opened and marked as solved, but the problem keeps coming up.

I had the same problem as the OP by the way.

Me too …but my way around it is to create the profile and switch to it right away. Then you have both the default and the newly created profile. If you ever switch back to the default profile the newly created profile is lost.

I had tried that too, the profile was deleted again.

I hadn’t found a profile file anywhere, so I don’t think it was created.

I installed Konsole on my Arch Linux, created a new profile, changed a few things, set the profile as default. no profile was created in the konsole folder. after a restart the profile disappeared. LXQt is used as a DE on both operating systems, maybe it has something to do with that.

Edit: my first konsole installation was on my EnOS installation, on Arch is only for testing.


I’m trying KDE on VM and got same issue. What I did is to create the new profile, just with the name, mark the checkbox to setting it as default, save and restart Konsole. The new profile is still there and I can change all settings with no more issues.

1 Like

tried KDE in the VM too, it works the way you explained, so click the checkbox. but it didn’t work that way on LXQt(both laptops). I’ve tried a few variations, also with the checkboxes.

Well it works for me?


Edit: If i now set it to the original default profile then profile1 will disappear.

I’ve just installed EOS + LXQT on VM and didn’t work that way, then I’ve tried:

  1. Create the new profile (only type the name) and save it without modifications. Close Konsole.
  2. The new profile is still there, I’ve changed colors, font and other settings. Close Konsole.
  3. Again, is still there, this time I’ve marked the checkbox for default profile. Close Konsole.

Voilà! It worked. After restarting EOS, the new profile still exists.

1 Like

create a profile and save it directly as explained in point 1. was the first thing i did(the profile did not exist after closing and opening Konsole.). didn’t work on both my systems and in the VM. as I wrote before, I had tried a few things and in the end only the variant that I described in my first comment worked, only then could I easily create other profiles from the menu.

Thanks. I’ll give that a try

1 Like

At this time, the issue persists.

hello @ragnar54590,

welcome to the purple universe :enos_flag: :enos: :penguin_face: :rocketa_purple:

did you try the instructions from my first comment?

I have found that if you create two profiles, it more often than not will work.

Create a new profile.
Create a second profile before closing the settings. Set it as default.
Switch to one of the new profiles after closing the Konsole settings.

When you next open Konsole, one of the profiles (sometimes both!) has usually stuck around

1 Like

This is the way i found it works also and if you switch back to the default profile the one you created disappears. I have been using the profile i created without issue for a while.

1 Like

I’m sorry for bumping but I was going to create a topic about this… one thing complains, another thing… this stupid forum! >:O

This was driving me crazy so I gave up totally on Debian KDE, besides the very first start right after successful install giving me a totally-black wallpaper. Chose Spiral instead which is still on “Bullseye” but didn’t care, I do have Debian MATE “Bookworm testing” lying around somewhere.

Just installed Cassini: KDE over XFCE and had unpleasant thoughts and began to regret it until I found this topic. Thank you.

Just installed KDE. What’s up with Konsole?? I created a new profile, changed font size and then switch to it. Besides the profile disappearing the first time, the edit button under Settings>Manage Profiles gets greyed out. I can’t change the terminal settings for this profile. Is there a way to make it work?

Strange, seems last time I tried KDE in the Spring this was all working. Some kind of bug :beetle: in there.

Edit: actually each time I close Konsole it kills my saved profile :exploding_head: probably going to go with another terminal pronto. That’s my first 5 min with KDE :smiling_face_with_tear:

Edit 2: Yakuake terminal it is. the force with me may be.