Crash after sleep or suspend

Happy Easter everyone,

I bought a new l laptop a used Huawei Matebook D16. I installed Endeavouros, which worked great for the last year on my tower pc, but with the laptop i have the problem to crash after sleep mode.
So i installed Linux Mint to try if the same problem occurs. There i can close the lid and go to “suspend” alias sleep mode and log in again. If i set it the suspend mode via start button it crashes again. So it does not seem to be distro related, more related to this laptop.

On both the log in windows appear after button press, but on both it crashes exactly there.

The journalctl does not log anything after entering the sleep mode, only when have to restart it starts logging againg.

Mar 31 09:30:42 saeniv-RLEF-XX systemd-sleep[3521]: Entering sleep state 'suspend'...
-- Boot 40d18d3bb89048a09a20a0c0077951c5 --
Mar 31 09:31:32 saeniv-RLEF-XX kernel: microcode: microcode updated early to revision 0x430, date = 2023-06-07
Mar 31 09:31:32 saeniv-RLEF-XX kernel: Linux version 5.15.0-101-generic (buildd@lcy02-amd64-032) (gcc (Ubuntu 11.4.0-1ubuntu1~22.04) 11.4.0, GNU ld (GNU Binutils for Ubuntu) 2>
Mar 31 09:31:32 saeniv-RLEF-XX kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.15.0-101-generic root=UUID=bbd83527-1bbe-4c48-9c38-9a2f59a72c3e ro quiet splash

Maybe somebody has an idea. I was searching our forum, but nobody had a solution or their cases are still open.

! I am back on EOS!

Don’t get me the wrong way but perhaps Linux Mint Forums may be the right channel to get assistance on this one?

He mentioned that the issue occurred with the EOS installation on his laptop as well. He installed Mint just to see if he could reproduce it on Mint.

Did you hard reboot the computer when it crashed?

1 Like

Yes. I saw that. No logs from a current EnOS’ install, how would that help troubleshooting?

But, by all means, you are of course free to try.

@pebcak I tried Linux Mint to know if it’s distro related, I am back on EOS.
I will add the log from EOS later, but it was the same, there was no entry, like in the added one from Linux Mint. But you are right my mistake.

@anthony93 I had to hold the power button to restart, so i guess it’s a hard reset.

1 Like

Relax. I was only pointing it out in case you missed it. There wasn’t any insinuation at all in my earlier comment. Though I do apologize if it came across that way.

That’s probably why there were no logs.


No problem! Sorry if I came across rather harsh and rejecting.

No worries! I am sorry, I came across also a bit sideways in my replies!
So apologies to both of you!

1 Like

Don’t worry and thank you for the apologize, but you could not know what i did if I havn’t written it in the description.

Ok that is something i did not know, thank you. Maybe i can access the terminal mode via Ctrl + Alt + F1/F2 and force a reboot or at least get a useful log. I will try later.

1 Like

All good. No apologies necessary. I saw your reaction and thought I commited a faux pas or something.

1 Like

May need to use F3 for TTY and F2 back.

With TTY I can’t use the keyboard, but there is something logging i need to google it, later.

I tried to access TTY again, but i never got these messages again.

Is there a way to keep logs even after a hard reset? I haven’t found anything in the last two hours.

Frankly, after cross testing it with Mint, if I wanted to go with EndeavoursOS anyway, I would first reinstall it and then comme back for investigation.
It will be less painful imho.
And happy Easter!
:rabbit: :bell: :egg:

Thanks for your input, if you would have read the other posts than you would know that i am back on EOS, since the beginning.

If the machine contains any personal data you want to keep, I’d suggest backing it up to an external drive before doing anything else.
Hopefully you can boot with the USB installer stick and then backup your data .

The you could show some information about the machine by posting the output of command:

inxi -Fza | eos-sendlog

When you get the system up again (e.g. by reinstalling), then you probably want to look for the REISUB thread on this forum. It provides a very useful tip how to avoid a hard reset (which may save the disk from corruption).

1 Like

Thank you very much. The laptop is close to new and contains no personal data yet, the data is safely stored on my old one, when i figured out the quirks with this one, i will move.
I can start the system without problems after a hard reset. The system runs great expect the freeze after sleep mode.

The output of

inxi -Fza | eos-sendlog

  Kernel: 6.8.2-arch2-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: initrd=\8ab506a4f1ba447295b6754d8382f983\6.8.2-arch2-1\initrd
    nvme_load=YES nowatchdog rw
  Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A info: frameworks v: 6.0.0
    wm: kwin_wayland vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HUAWEI product: RLEF-XX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: RLEF-XX-PCB v: M1010 serial: <superuser required>
    part-nu: C100 uuid: <superuser required> UEFI: HUAWEI v: 1.27
    date: 06/19/2023
  ID-1: BAT0 charge: 61.1 Wh (100.0%) condition: 61.1/59.4 Wh (102.7%)
    power: 6.5 W volts: 13.0 min: 11.6 model: SUNWODA HB5781P1EEW-31T
    type: Li-ion serial: <filter> status: discharging cycles: 2
  Info: model: 12th Gen Intel Core i5-12450H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x432
  Topology: cpus: 1x cores: 8 mt: 4 tpc: 2 st: 4 threads: 12 smt: enabled
    cache: L1: 704 KiB desc: d-4x32 KiB, 4x48 KiB; i-4x32 KiB, 4x64 KiB
    L2: 7 MiB desc: 4x1.2 MiB, 1x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 525 high: 888 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 761 7: 653 8: 400 9: 888 10: 799 11: 400 12: 400 bogomips: 59916
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling mitigation: Clear Register File
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Huawei driver: i915
    v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1920x1200 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.3-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a3 memory: 14.99 GiB unified: yes display-ID: :1.0
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Huawei
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.8.2-arch2-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:2 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 476.94 GiB used: 8.32 GiB (1.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: PCIe-8 SSD 512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    tech: SSD serial: <filter> fw-rev: YM00D217 temp: 30.9 C scheme: GPT
  ID-1: / raw-size: 459.07 GiB size: 450.79 GiB (98.20%) used: 8.22 GiB (1.8%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16.89 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 15.35 GiB used: 2.06 GiB (13.4%)
  Processes: 255 Power: uptime: 7m states: freeze,mem,disk suspend: s2idle
    avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.13 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 978 libs: 242 tools: yay Compilers: gcc: 13.2.1
    Shell: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33

I did read the other posts… it was absolutly unclear to me you were back on EOS, I missed that bit… my bad

1 Like

You are right it was not easy to find, so now i added a fat line in my first post for everybody else.

Yep, the logs coming from another distro were confusing, I missed the “back on EOS” part, don’t worry it’s sunday :sweat_smile:

that is a good idea

as for the sleep problem there’s always t̶i̶s̶a̶n̶e̶s̶ the wiki (no idea if anything will be there :upside_down_face:)


Reisub is very cool. Thank you guys.

I will search further for the sleep mode lssue over the next days.

1 Like