Crash after sleep or suspend

Thanks for the inxi output.

So far the only things I’d suggest is trying one or both of

  • x11 instead of wayland
  • the LTS kernel
1 Like

Good morning,

I tried the LTS kernel and Zen kernel no change.

I tried X11 instead of Wayland i can access, with Ctrl + Alt + F2, the log in screen after the sleep freeze. The keyboard is working, but the password is always wrong. So i guess the input is messed up during the freeze.

So maybe it is a hardware or firmeware issue, with the Huawei Matebook.

Hardware problem is a reasonable possibility.
Something like (in probality order in my view):

  • disk is failing, may need a new disk?
  • RAM has problems, a good idea to test it
  • power source is inadequate

The laptop is close to new, but i will try with external hard drive. For the RAM i could run a memtest. Power source with or without external power supply does not make a diffrence.

So I installed EOS on an external HDD and had no problems with the sleep mode.

I opened the case and there is a Nvme ssd built in without any branding. So i will buy a new one or life without sleep mode.

1 Like

Just thinking, did you install everything yourself to the laptop from scratch?
As it was a used machine, there might have been issues on the disk already before you bought it.

So, if possible, fully re-creating the disk partition table and then reinstalling everything could make a difference (or not…).

Maybe there was an issue with the disk from the beginning. I guess the laptop is a little over one year and had windows 10 on it.

I created a new partition table and now i can access the sleep mode once and then log back in again. If i try it a second time I get the messed up log in screen where i can use the keyboard, but every input gives the same output symbol and i can not log or do anything else. The picture in the background is also half loaded and the rest is white. I will add a picture after work.

So the creation of a new partition table helped a little, but the sleep mode is not working two times in a row, but at least once.

Ok, for me it seems disk is failing and a new one is needed.

Still another idea: motherboard firmware/BIOS update if one is available. But that might not help and is a bit risky too.

1 Like

It appears that the only way to update BIOS/firmware is via a proprietary Huawei Windows application. The BIOS is not available to download on their website and it’s also not available via LVFS/fwupd. The support website says their app is the only approved way to do so.

I agree with others, my first guess is a bad SSD. My second guess would be the BIOS/firmware update.

1 Like

Thanks for all your help.

Before I installed EOS, i ran the Huawei PC manager to update the latest drivers and update to the latest BIOS, but everything seemed to be up to date.

I will copy my Windows system to my external ssd, then I will try it with the empty M.2 ssd. M.2s are quite pricey in comparison to last year, so i will try the disk i have at home.

1 Like

As always thank you very much for all your help.

I used the old M.2 from my gaming pc and had no problem with the sleep mode, so the SDD was starting to fail. I never would have guessed that without your help.

I come closer to my goal to switch completely to linux.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.