"...conflicting dependencies- openexr and ilmbase are in conflict"

I am repeatedly receiving the following error message…

Failed to prepare transaction: conflicting dependencies openexr and ilmbase are in conflict

Here’s a screenshot of the message.

I remember clicking on some prompt that mentioned openexr and ilmbase but I don’t remember much more than that.

I’d appreciate any help or advice.

By the way, I installed EndeavourOS a few days ago. I like it. It works fine.

I’m not a techie therefore I find the endless debates about “Linux flavor A vs Linux flavor B vs Linux flavor C” to be mostly irrelevant. Except for package management (for example, I wearied of having old versions of applications), I don’t notice any significant differences between EndeavourOS and “buntus” (Xubuntu, Lubuntu, etc) or Puppy Linux, all of which I have used previously. Once I set up my applications and environment the way I like, they all seem to work the same for me.

If I hadn’t wanted updated applications (via Arch’s rolling releases) I’d still probably be using a variant of Xubuntu.

As to the Arch fanatics who make an argument analogous to, “People who drive cars should learn to mine iron ore, open a steel mill, and manufacture their own cars.” Well. I’ll leave them be.

Hey @KenE, good?

Here, i dont have this issue. But when i update the system via pacman -Syu, it ask me if i want to “replace ilmbase to extra/openexr” and i accepted. I don’t know if you do so.

Can you tell us more details? like, if you do something to receive this error message or it appear from nothing. You update the system?

Hello.

Answer is already given.

1 Like

Hi @fredericofavaro,

Thanks for your suggestion.

I selected Replace ilmbase with extra/openexr? [Y/n] but I received the following error message, error: failed to prepare transaction (could not satisfy dependencies) :: installing pacman (5.2.0-2) breaks dependency 'pacman<5.2' required by kalu

Here’s a screenshot…

Thanks,

Ken

Hello.

Just remove Kalu. It is not compatible with pacman 5.2.

See this thread: Pacman update breaks Kalu dependencies

3 Likes

Hi @FredBezies,

Thank you! Your solution solved it!

I ran…

sudo pacman -R kalu

and then updated EndeavourOS by running…

pacman -Syu

Thanks,

Ken

2 Likes

Yeah, the problem is a incompatibility between kalu and Pacman. Since I remove kalu right after install endeavours I don’t get this error. :slight_smile: