Coming from Manjaro and there is trouble installing Endeavour Os due to grub installation error

I’m a Manjaro user and recently I tried to install Endeavour Os and prompt with an error where it shows Grub installation error. I tried following the fix listed in the wiki with no vain. Anyone knows how to iron this problem with a step by step procedure.

Specification:
Intel 7700HQ
Nvidia 1050TI
Intel HD 600
16GB RAM
250GB Nvme Primary
1Tb SSHD Secondary

did you planning a dual-boot ?

Nop I didn’t plan to dualboot. Want to use it as primary os yet i keep getting grub error and when i follow the instruction to repair grub according to wiki yet there is an error. So i flashed manjaro and there is no such error. Smooth installation. What might be the problem ?

Welcome!

Could you please give more details, e.g.

  • how exactly did you create the installation media
  • are you using legacy BIOS or UEFI system
  • exact error messages or pictures about the error

You might want to use some pastebin like service for showing the details.

Will update as soon as i reinstall endeavor OS.

I don’t know if the following suggestion will be pertinent to you but here is what I have found out regarding installation:

When the Live Disc mounts, you should go into the Applications Menu and find GParted. Then, using GParted, you should reformat all of the drives on your computer. This will remove every previous operating system you had installed on the computer.

After you do that, the installation should proceed quickly and easily (in all of my cases so far, the installation process has taken under seven minutes).

I hope that this information is of some help to you - and welcome to EndeavourOS.

Lawrence

1 Like

@noir12 Welcome! Anyway you can give a clearer explanation with more details. Do you have a cell phone you could take a picture of the error and post. I have a suspicion that the error is related to your Nvidia 1050ti and not a grub error per say. As @manuel has said we need more details. How did you create the live ISO? I’m assuming you are installing on a UEFI system according to your hardware specs? Then we need to know the specifics of the error you are getting? This way someone can help you. Thanks.

This is the error.!

hello, tell us how have you installed: step by step, thank you

I choose the 3rd installation method erase and install endeavour os by replacing the partition with the new os and failed. Then I did manual partition with 300mib boot uefi partition with esp flag and then swap with 17gb and the rest root. Yet shows the same error. And after that I installed Manjaro without any error.

as our distribution does not have the same version of calamares

Is there any way for me to install without eny error. Since the error prompted was lack of storage. Is there any workaround.

It looks to me to be having a problem writing to the EFI partition. How did you create the live ISO? Are you using the 2019.07.15-x86_64.iso? What software did you use to write the ISO? I use etcher on Linux. When you created the partitions did you format the EFI partition as fat 32? I know it shows that. I would try deleting all the partitions first and start from new. The picture you show looks like a different installer with only 3 options? that’s why i ask! Sometimes file systems have issues and clearing it all might help. Also make sure in UEFI bios that secure boot is off and fast boot is off. This is important.

you have 16gb of ram so I don’t think you need a swap partition…
try creating just one partition which is ext4 and see if it lets you install on that…
Good luck!
Edit: noir est un couleur Francais, alors si vous etes dans la France, bon chance! :smiley:

1 Like

personal, I always make my usb drives with suse studio imagewriter

1 Like

I did the same. I used suse studio image writer available in Manjaro.

ditto for me suse imagewriter is the boss!
balena etcher is load of :poop: since balena bought it out
quote from wikipedia… ‘balenaEtcher uses Google Analytics and Mixpanel, even when the ‘Send anonymous usage data’ checkbox is checked off’
more big business ignoring your privacy concerns…plus you go to their website and they say ‘Build your IOT project’…IOT is a euphemism for ‘internet of sh!te things’ :stuck_out_tongue::rofl:

2 Likes

dd worked for me fine enough… there is a esp flag , i believe the mount point of calamares is /boot/efi , grub of manjaro also differs, it uses the grub-quiet…, basicly to quiet the grub to show the vendor logo as bootsplash … systemd-boot does also use in some cases esp flag…

not i got so much idea of uefi systems … did you mounted esp flag somewhere in calamares which option ?

All i can tell you is that when something isn’t working then try an another approach. There is an issue with it writing to the file system and that can be caused by firmware conflicts from your m.2 drive sometimes and or the installer or some other software. It happens. Make sure secure boot and fast boot are off in EUFI. Check your ISO…maybe download another just to see. Clear out your m.2 drive and start fresh with a newly created GPT partitioning scheme and either install using erase disc and or use manual partitioning. If you do manual partitioning then you need a EFI partition formatted to fat 32 and a root / partition formatted to ext4. The ESP or EFI partition or has to flagged as /boot/efi. You can also create a swap if you so desire but it is not really necessary with the hardware you have. Never give up. It is not the fault of the installer or the distro. It is most likely a software\hardware glitch that happens. Hopefully trying some other way will get past the issue.

I use Etcher bin from the AUR and have used it for a long long time on Linux. No issues ever. That’s been my experience with the software. I don’t want to go off topic here on the thread so that’s for another one.