Chromium browsers launches very slow

Yes, it should. But it doesn’t. I think this is related to EndeavourOS because arch installation I used previously didn’t have such a problem.

So it has an Nvidia but you disabled it? I would add amd_pstate=passive and update grub if using grub. If using systemd-boot then it gets added differently. I don’t know if you have grub?

Well it’s not related to EndevaourOS for two reasons. I have EndeavourOS and i don’t have this problem. Secondly EndeavourOS uses Arch repos so it has everything that you get from Arch. The only other software is from the EndeavourOS repo. We don’t use that kernel so I don’t know if there is an issue with it.

Also if this is set up from the Arch wiki link that you posted then it’s not really an EndeavourOS installation.

Yes, there’s option in asusctl software which enables only integrated graphics. I’m using grub.

That’s true, but installer is different and might mess things up.

I’ll try that amd_pstate and stock kernel, but I don’t believe this to change anything. Worth the try tho.

I’m on EndeavourOS. Installed chrome. And it is very slow. When it was done on arch it worked fine. Why it should be arch problem?
Do you think the kernel has something to do with this? I’ll try stock one and report back.
Should I try enabling Nvidia GPU as well? Ok, will try that.

Have you ever tried installing EndeavourOS with the current ISO?

Edit: Obviously you have gotten more familiar with how your hardware works. This does help for sure.

I downloaded it less then a week ago, is it the current?

I think chrome might be having an issue with hardware acceleration. That might be why it’s so slow to load.

It should be Cassini. I’m not pushing you to do this. I’m just asking? I know you may have had issues with this laptop in the beginning. Now you are more familiar with it’s quirks and hardware and setup. The ISO has nvidia on it but you would have to enable the hardware if you were going to try installing it with nvidia drivers. There is an option to boot nvidia in the menu on the live ISO. It will automatically pick up the amdgpu on install.

As @s4ndm4n pointed out Chrome might be having an issue with hardware acceleration. But i find that hard to believe that it should. But anythings possible.

I also see this on the link you posted but i don’t know how accurate this is. Because it uses nvidia-dkms as far as i know.


When installing EndeavourOS don’t use the option with Nvidia drivers preinstalled, this installs configs with might conflict with supergfxctl and installs the driver with works only with stock kernel. Use the default install option then install nvidia-dkms post install.

I think I’m already using latest iso, so what’s the point with reinstalling it once again and going through the hustle of configuring ecryptfs? I might just go back to pure arch at that point.

I’ve used that Nvidia option because overwise it would even let me start installer. Only mouse pointer and a dark screen were shown for non-nvidia installer.

See my previous posts about hardware acceleration: I’ve tried turning it off in Vivaldi but no success.

Just so you are aware the latest ISO has both systemd-boot and grub on the installer. Systemd-boot is default so you have to select if you want grub. Also it is using dracut now instead of mkinitcpio.

Maybe it’s a bit outdated? Because I think I looked which Nvidia was installed and it was dkms one afaik

Yes, and I’ve chosen grub. I just checked and iso was downloaded on Jan 26, it’s cassini 22_12, so I guess it’s the latest, isn’t it?

I thought you were using the install from the link you posted? So that wouldn’t be an EndeavourOS install is what i meant. You could just try the current kernel. :thinking: What is the reason you have Nvidia disabled anyway? Doesn’t it automatically switch for graphics? Too much battery drain?

Yes, too much battery drain. But even though it’s plugged right now, I’m not using GPU, so having it disabled will also make CPU a bit faster (more thermal headroom, in Windows it easily gets up to ~90W or so).

I don’t think he needs a reinstallation. Just install the normal kernel or the LTS rebuild grub. And restart using that kernel. Might be that the ASUS kernel causing an issue.

I understand that. How is it disabled? In the UEFI Bios set up? I still think i would want the drivers installed and set up before i disabled it just to make sure the hardware is working properly.

I’m not suggesting user reinstall unless they want to. My issue is it an EndeavourOS installation or an Arch installation via the link provided.

It’s using a different kernel.

I installed kernel from that g14 repo. So basically I now have 2 kernels: stock and g14.