Chromium browsers launches very slow

I’m using KDE Plasma. Just installed Vivaldi and it takes 30 seconds to start. Checked stable and snapshot versions.
Also the same happens with Chrome from AUR.
I found this:
Tried adding notifications widget but no success, unfortunately.
Any ideas what’s going on and how to fix this?

Me neither I don’t know, What I have observed is that all chrome based browsers have become slower than molasses.
Only Firefox is 1/2 decent. Not much help, I know but that’s all that I have to offer.

I use Firefox and Chromium without issue on KDE. I don’t need any other borwser than Firefox but i use Chromium occasionally.

Edit They are not slow or laggy or lacking. They launch instantly. They are just as secure as any other mainstream browser.

Edit: You can see here for example. When i say they open instantly I mean directly after i click on the icons.

simplescreenrecorder-2023-01-29_22.58.26.mkv (1.2 MB)

simplescreenrecorder-2023-01-29_22.56.46.mkv (1.0 MB)

This has nothing to do with a fact that you have quite powerful computer with lots of RAM?.. :stuck_out_tongue_winking_eye:

Well i suppose it could. It opens fast doesn’t it! :wink:

Have you tried turning off hardware acceleration?

I’ve tried it just now. No changes, same 30 seconds to start Vivaldi. Btw in pure arch it worked just fine, so no idea why it happened.

Try starting it from a terminal and see if it outputs anything pointing to something :thinking:

1 Like

Have installed any plugins? Or just vanilla?

Chrome has no plugin whatsoever, Vivaldi is also very slow even without the plugins.

When either of the browsers running is your CPU usage goes up or remains at a low percentage?

It doesn’t print anything, however, I was able to obtain logs:

BTW, seriously?

No. My CPU is 6900hs, so wouldn’t believe it’s just too slow. Firefox launches immediately, just chromium-base browsers are slow.

Wait, it kinda goes up:

Seems like the Chrom engine doing something while it’s loading. That’s why it’s slow. I’ve been using Chrom-based browsers for a long time. Currently, I’m using Brave. It’s much faster than the two browsers you mentioned. But I don’t think switching to another would slow your issue. I’m not going to be that helpful but it seems like something in your distro makes the loading slower.

In my experience it’s usually some other software that cause problems with browsers being slow to load. Maybe you could give your hardware output? Post the url

inxi -Faz | eos-sendlog

Here it is:

 Kernel: 6.1.6-arch1-g14-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: ibt=off pm_debug_messages amd_pmc.dyndbg="+p" acpi.dyndbg="file
    drivers/acpi/x86/s2idle.c +p" BOOT_IMAGE=/boot/vmlinuz-linux-g14
    root=UUID=f64e21ff-1e31-46d5-98f2-755c5b11d8ec rw nowatchdog
    nvme_load=YES loglevel=3

What kernel is this you are running? I also see some odd kernel paramaters I’m not familair with so I’ll have to look them up.

Your graphics are amdgpu so why do you have ibt=off kernel parameter? Why all the debug kernel parameters?

Edit: Does this laptop have Nvidia. I don’t see any output for it.

Current kernel is 6.1.8-arch1-1 Your system is a Ryzen 9 6900hs. This is more powerful than my Ryzen 3800X. I’ve shown you in the post two video’s that show how fast the browsers open. Almost instantaneous upon clicking on the icon. Your system should work like this as well.

This is asus-linux kernel. No idea what these parameters are, I just installed it according to

There’s an Nvidia GPU, but it was disabled.