Charging not shown on battery icon

I was on battery power until it dropped to 5%, then I plugged in my computer.
The battery icon in the system tray, however, continues showing 5%. I checked all the connections and they are good.

1 Like

Is it charging?

What’s the battery health/capacity like?

It’s still pretty good because the PC is not old (2019) and hardly used.

Update after 1 hour: the icon shows 69% now, so the charging is working, that’s good.

That still leaves the issue of why the icon did not react immediately. OTOH, I could just classify this as a “bug”,leave it that., and attend to other, more important issues.

1 Like

Sounds very similar to

1 Like

Yes, it is exactly the same problem. I am not sure what he means by a “full system update”, but if it is yay -Syu, I do a full system update every day.

I am not confident enough to try the lts kernel, so I will wait till it gets fixed in updates as someone mentioned, or live with it.

Actually the problem is not solved, I thought it is solved by a system update, but I find it still has the issue… now the issue will only occur after a suspend…
I have open a new topic here, since the previous one is closed…

And really sorry for didn’t clarify what have I update (It closes when I want to reply), here it is:
eos-quickstart (1.3-1 → 1.3-2)
hwinfo (21.80-2 → 21.81-1)
inxi ( →
libbluray (1.3.0-2 → 1.3.1-1)
libbytesize (2.6-3 → 2.7-1)
librsvg (2:2.54.3-1 → 2:2.54.4-1)
pcsclite (1.9.7-1 → 1.9.8-1)
qt5-base (5.15.4+kde+r164-1 → 5.15.4+kde+r168-1)
vlc ( →
welcome (3.25-1 → 3.26-1)
libass (0.15.2-2 → 0.16.0-1)
zimg (3.0.3-2 → 3.0.4-1)
svt-av1 (0.9.0-2 → 1.1.0-1)
kbd (2.5.0-1 → 2.5.0-2)
ffmpeg (2:5.0-7 → 2:5.0.1-2)
ffmpeg4.4 (4.4.1-5 → 4.4.2-2)
libavif (0.10.1-1 → 0.10.1-2)
smbclient (4.16.1-4 → 4.16.1-5)

After those the issue fixed to an extent, but it will behave bad as usual after I suspend and wake up

1 Like

Thank you for this update :upside_down_face:

It seems that the problem is a bug in EnOS, so we’ll have to wait for a fix. I am not going to undertake anything for now.

1 Like

My friend with a vanilla Arch with kde have the exact same issue as me, not sure what cause it…

1 Like