Real time update battery life

Hi, I am using EndeavourOS with kde on ROG G14 2022 GA402RK. The problem is sometimes the system does not update the battery life (neither on the battery icon at bottom nor in the Energy info), the percentage just keeps the same all the time.
But if I close the lid or just let it sleep, then re-login, OR plug the power cable to charge it, then the battery life is updated in real time as expected…
Any idea how to fix this?

(Might be useful:
as in the image:
only when the battery life is updated in real time the graph will show, otherwise it won’t show the graph and just have the info below if the battery life update is “stuck”)

Given this is new hardware it sounds like something that would be fixed in future kernel updates.

I see…, I try to use upower -i … to check, but still not an updated power status, quite annoying because each time I want to know the battery level I need to sleep and wake up the laptop…

1 Like

Getting the Same error, Sometimes battery percentage display gets stopped and I have to see from cat /sys/class/power_supply/BAT0/capacity

I am not sure if this works, but the upower command

upower -i /org/freedesktop/UPower/device/battery_BAT0

does not work for me.
Anyway, I will check if it works, thank you

Actually this works for me! Although keep using command is annoying, at least I have some ways to check the remaining battery life.

For now I will leave this topic as open in case anyone have a better solution :slight_smile:

Maybe install and boot the linux-lts kernel to see if the problem exists there. I’m assuming you are currently using the linux package.

uname -a in a terminal will tell. if 5.18., you are on current. if 5.15., that’s an LTS kernel.

I am using the stock kernel, 5.18. But actually I also have the G14 customized kernel by asus rog, but also not working on that.
I could try the lts kernel, but I think I will loose the bluetooth control since it is just updated for my chip in the latest g14 kernel

it may be worth a try to see if the linux-lts kernel has the same problem (or does not have the same problem)


as you can see it is stuck at 98. but in real-time I have 86 percent.

1 Like

did full system update yesterday, the problem was solved, It is updating real time. I also tried the lts kernel, seems also works on that kernel.
But I am not sure what fixed the problem.
Any way, it works now

Which packages were included in the


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.