Changing root fonts size in Xed text editor?

I doubt this is really an Openbox problem, but here it is anyway…

I can’t for the life of me get the root xed to change its font size from ‘Source Code Pro 10’. Which is unusable it is so small on my display. The switch in the Xed’s preferences where, when switched, allows you to choose other than the system fixed width font is locked by a little tick.

I can use sudo to start system configuration applications in Openbox to change everything that I want to (thus far) for root. But not for the text editor, which is likely the most important. If I can’t fix it, I’ll delete the Xed & use something else.

Any help will be much appreciated. :slight_smile:

Don’t run GUI programs as root. Your problems seem to be the consequence of that. Probably some permissions got messed up. This is where you should look first.

1 Like

There is no alternative to using root access for files that I need to edit from time to time. These days I prefer to use a GUI editor to vim or nano.
(/etc/default/grub was the initial cause of this trouble, but I do often need to edit files requiring root access)

I’ll remove the text editor & its ~/.config file & then reinstall it, if that doesn’t solve the problem then I’ll use one of the other GUI editors out there, there are plenty to choose from.

R&R’d the the editor & its config files in both user & root & it still has the same problem.

So I will delete it now & replace it with another editor that I know. I hadn’t use Xed before, so I was looking forward to checking it out, it looks like a nice editor. Maybe sometime in the future.

[edit:] Featherpad text editor lets you modify the size of the font in the menu, outside of its preferences settings. It works great in both user & root modes, so I’m happy. :slight_smile:


It’s your system, you can do whatever you want. Just don’t say you weren’t warned. :man_shrugging:

1 Like

I feel edgy today, why not run wine as root :rofl:

1 Like

Yeah, about as smart as pouring water over your toas  computer… :rofl:

1 Like

Thanks for your concern @Kresimir . :slight_smile:
I’ve been using Linux as my main OS since 2005, so I’m not one of your new users… :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.