Cassini installation with "questionable UEFI firmware

Some of this has been discussed in other post but to eliminate confusion I started a new topic.

I tried installing the Cassini iso from a USB stick on an old Intel generation 2 core i7 system. This PC in the past has caused some Linux Distros to question my EFI firmware and ask for conformation to force UEFI booting.

At the boot menu I chose the first option and hit enter. There was a ~10sec pause with a blank screen and then a bunch of errors about a blacklisted hash error; same error over and over.

But it eventually let me install. I noticed the new Boot choice menu but I had to choose the Grub because it calls out that need if you use BTRFS and want to boot snapshots,

So I’d classify this as a successful install if you ignore the strange errors at first.

However, I tried the same thing on a 2011 Macbook Pro which has their version of EFI firmware and it crashed as soon as you hit enter on the bootloader menu for the installation choice. Again using the default first choice for no Nvidia graphics.

I was able to go back to the Artemis Nova ISO and install that and allow the upgrade process to move the Macbook to Cassini without any issues. In that case I used the Online install of EOS-Plasma and it installed all the latest packages so I had Cassini on the first boot.

So for my Macbook the only way to get Cassini is to start with the Artemis Nova ISO and not the Cassini ISO. You don’t get a boot loader choice this way but for me I need Grub anyway since I use btrfs bootable snapshots

1 Like

Did you try booting from Cassini using nomodeset as a kernel parameter?

I looked at the ISO and it have these kernel parameters:

options archisobasedir=arch archisolabel=EOS_202212 cow_spacesize=10G copytoram=n module_blacklist=nvidia,nvidia_modeset,nvidia_uvm,nvidia_drm,pcspkr nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes

I just added nomodeset to the end of the list and it had no effect. Still kernel paniced. I didn’t edit the file I just entered ‘e’ at the boot menu prompt and went to the end of the line and entered it.

1 Like

not sure it will help but I ran efibootmgr and got this response:

[jim@jim-macbookpro81 ~]$ efibootmgr
BootCurrent: 000D
Timeout: 5 seconds
BootOrder: 000D,0010,000E,0000,000F,000C,0007,000B,0008,000A,0009,0006,0005,0004,0003,0002,0001,0080
Boot0000* ubuntu        HD(1,GPT,2ee9a751-045e-4220-8656-5b4ea9933768,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Linux Boot Manager    HD(1,GPT,e130a6cf-9eba-4c11-a245-d0d3d58bfb71,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0002* Pop!_OS 21.04 HD(1,GPT,944a62de-df68-463a-9374-a4b1e0405880,0x1000,0xf8fff)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0003* Linux Boot Manager    HD(1,GPT,05429588-9965-4571-9fba-4128e4fdc67d,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0004* Linux Boot Manager    HD(1,GPT,be56b8c0-225b-42a0-9b56-2775badf0b1b,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0005* Linux Boot Manager    HD(1,GPT,ea862622-9e36-4934-8780-ed36e71d7f04,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0006* Linux Boot Manager    HD(1,GPT,f1ab5b45-0ce3-4abe-a493-3e3a9604d751,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0007* GRUB  HD(1,GPT,ed531e43-3309-423f-a6ba-9ad7ec7113ea,0x2800,0xf2000)/File(\EFI\GRUB\grubx64.efi)
Boot0008* Manjaro       HD(1,GPT,a2c74964-32fd-124c-9ed1-9dd1f42fa5de,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0009* Linux Boot Manager    HD(1,GPT,22c09947-ba2a-4f11-91c4-7b457db53eaa,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot000A* Linux Boot Manager    HD(1,GPT,261d83cc-d00d-4777-aba5-d44670652eaf,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot000B* Linux Boot Manager    HD(1,GPT,a91f41fe-a56c-4500-8a45-b7cea555b4d2,0x800,0x100000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot000C* Pop!_OS 21.10 HD(1,GPT,ba0791bc-a599-4d78-9336-cda4d493fbfa,0x1000,0xf8fff)/File(\EFI\systemd\systemd-bootx64.efi)
Boot000D* endeavouros   HD(1,GPT,c4ff6370-8bf7-f743-a5ea-8827b756ae50,0x1000,0x96000)/File(\EFI\endeavouros\grubx64.efi)
Boot000E* Archlinux     HD(1,GPT,194e83e5-f7d0-4e47-ba6b-95746ec60b74,0x800,0x96000)/File(\EFI\Archlinux\grubx64.efi)
Boot000F* debian        HD(1,GPT,5fa28c89-6ac1-41a4-b33f-2a600f42bc5c,0x1000,0x8f000)/File(\EFI\debian\shimx64.efi)
Boot0010* rEFInd Boot Manager   HD(1,GPT,7ccbf09a-313d-8f4e-980d-ee1499732e9b,0x1000,0x96000)/File(\EFI\refind\refind_x64.efi)
Boot0080* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,d443b6da-4c60-463a-b28f-bf73d77deeb9,0x64028,0x1bd8a540)
Boot0081* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,081063b4-d14f-4c63-a7f7-a6716500de9f,0x64028,0x1bec0460)/VenMedia(be74fcf7-0b7c-49f3-9147-01f4042e6842,e798d229302de54aaf9d67b7f20e9305)/File(\09D1BFA2-7C4F-30BB-915D-5F1CE7D41C98\System\Library\CoreServices\boot.efi)
Boot0082*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,d443b6da-4c60-463a-b28f-bf73d77deeb9,0x64028,0x1bd8a540)/File(\System\Library\CoreServices\boot.efi)
BootFFFF*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,000019f7-7ff2-0000-3020-0000bd6c0000,0x64028,0x14d69da0)/File(\System\Library\CoreServices\boot.efi)

Maybe I should take some time and clean it out a little. Maybe not related to the problem but couldn’t hurt

This is the “about this system” info showing a MacBookPro8,1. Are there any UEFI data that I can dump out that would help? Now that we know the efibootmgr works like it does on a PC. This information below is from the Cassini that I installed as listed above. Artemis Nova install with pacman -Syu.

Operating System: EndeavourOS
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.1.1-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2415M CPU @ 2.30GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 3000
Manufacturer: Apple Inc.
Product Name: MacBookPro8,1
System Version: 1.0

inxi dump:

System:
  Kernel: 6.1.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Apple product: MacBookPro8,1 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-94245B3640C91C81
    serial: <superuser required>
  Mobo: Apple model: Mac-94245B3640C91C81 v: MacBookPro8,1
    serial: <superuser required> UEFI: Apple v: 87.0.0.0.0 date: 06/13/2019
Battery:
  ID-1: BAT0 charge: 41.4 Wh (79.3%) condition: 52.2/62.9 Wh (83.0%)
    volts: 11.7 min: 10.9 model: DP bq20z451 type: Li-ion serial: N/A
    status: discharging cycles: 652
CPU:
  Info: dual core model: Intel Core i5-2415M bits: 64 type: MT MCP
    smt: enabled arch: Sandy Bridge rev: 7 cache: L1: 128 KiB L2: 512 KiB
    L3: 3 MiB
  Speed (MHz): avg: 1323 high: 2900 min/max: 800/2900 cores: 1: 2900 2: 798
    3: 798 4: 798 bogomips: 18364
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Apple driver: i915 v: kernel arch: Gen-6 ports: active: LVDS-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0126 class-ID: 0300
  Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo
    bus-ID: 1-2:3 chip-ID: 05ac:8509 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa dri: i965
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: LVDS-1 mapped: LVDS1 model: Apple 0x9cc5 res: 1280x800 hz: 60
    dpi: 112 size: 290x180mm (11.42x7.09") diag: 337mm (13.3") modes: 1280x800
  API: OpenGL v: 3.3 Mesa 22.3.1 renderer: Mesa Intel HD Graphics 3000 (SNB
    GT2) direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  Sound API: ALSA v: k6.1.1-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:16b4 class-ID: 0200
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 14e4:4331 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1.3:8 chip-ID: 05ac:821a class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 465.76 GiB used: 4.33 GiB (0.9%)
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 043 scheme: GPT
Partition:
  ID-1: / size: 465.46 GiB used: 4.33 GiB (0.9%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 608 KiB (0.2%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 465.46 GiB used: 4.33 GiB (0.9%) fs: btrfs
    dev: /dev/sda2
  ID-4: /var/log size: 465.46 GiB used: 4.33 GiB (0.9%) fs: btrfs
    dev: /dev/sda2
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 65.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 194 Uptime: 5m wakeups: 3 Memory: 7.68 GiB used: 1.68 GiB (21.8%)
  Init: systemd v: 252 default: graphical Compilers: gcc: 12.2.0 Packages:
  pm: pacman pkgs: 958 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
[jim@jim-macbookpro81 ~]$ 

I would definitely clean up the efibootmgr entries either way. There’s nothing really special about the hardware.

Do you still keep OS X on the mac and dual boot?

I cleaned up the efibootmgr entries. Only 1 now.

No OS X for me. Apple makes great hardware but their OS is better than Windows, but not close to Linux.

1 Like

Man, it seems to be affecting all kind of Macintosh computers… as I said on my own post. It is also affecting my dad’s Mac Pro 5,1.

added from test with USB iso ( with ventoy )
on macpro 2009 ( version mac3,1)
i get error missing architecture macintosh #14 ,
i can select iso , then try normal mode , but no screen after , for choose drivers videos

Having heard talk about Ventoy, I investigated it and started building up a collection of IOS that I could boot off of 1 USB Key. So having installed EOS using Artemis Nova on my MacBookPro and then upgrading to current, I thought about trying the Cassina IOS using Ventoy. So I booted up Ventoy on my MacBookPro8,1 and chose EOS Cassini to see if it would work.

Bottom line it worked. Once I chose EOS install (1st choice) I expected the Kernel Panic. however it completely booted into the install screen. I did not install since I already had EOS KDE installed using Artemis, but I got to that LiveOS screen where you can run the Calamaris installer.

Is this the one that you used Artemis ISO to install and then update?

Yes. Same MacBook Pro 8,1

I wonder if it’s only booting on that ISO because you actually have an install on it?

My next test will be to format that drive with a bootable gparted USB and then try ventoy/cassini

1 Like

i do just start uploading a clone rebuild of cassini ISO with latest packages and kernel (6.1) if you want to give it a try so we can bail out that the issue is simple something with the used kernel on the release ISO?

I will try the new ISO, but first an update on what I tested.

With Cassini on the MacBookPro8,1 via installing with Artemis trying to boot the original Cassini ISO fails as before.

If I use Ventoy and select Cassini ISO I have to select grub2 boot and not Normal, but then it will boot and allow me to install

that’s the same for me on 3 systems :wink:

The rebuilt 2023-01-01 ISO still kernel panics for me on macbookpro8,1

I think it’s got to be something between what Ventoy does with normal and grub2. Maybe try some grub kernel parameters with the Cassini ISO?