Cassini installation fails to complete while Running ("grub-mkconfig")

I used the logs tool to post the hardware and installation logs. I am using the latest ISO image version.
They are located here:

I’m trying to install it on a USB flash drive, with the “wipe” option. I’ve tried both “online”
and “offline” modes, the logs posted are from the “offline” attempt.

In addition to the posted logs, here is the output from efibootmgr

[root@EndeavourOS liveuser]# efibootmgr
BootCurrent: 001F
Timeout: 0 seconds
BootOrder: 0004,0019,0010,0011,0012,0013,0014,0015,001F,001A,001B,001C,001D,001E,0020,0021,0022,0023
Boot0004* Windows Boot Manager	HD(1,GPT,411cac63-b8eb-42ee-995b-30bccac86374,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000044000100000010000000040000007fff0400
Boot0010  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu	FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0012  Diagnostic Splash Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  Lenovo Diagnostics	FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0014  Regulatory Information	FvFile(478c92a0-2622-42b7-a65d-5894169e4d24)
Boot0015  ThinkShield secure wipe	FvFile(3593a0d5-bd52-43a0-808e-cbff5ece2477)
Boot0016  Startup Interrupt Menu	FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0017  Rescue and Recovery	FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0018  MEBx Hot Key	FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0019* USB CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot001A* USB FDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot001B* NVMe0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a400)
Boot001C* NVMe1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a401)
Boot001D* ATA HDD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot001E* ATA HDD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot001F* USB HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot0020* PXE BOOT	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0021* LENOVO CLOUD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,ad38ccbbf7edf04d959cf42aa74d3650)/Uri(
Boot0022  Other CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a35406)
Boot0023  Other HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f606)
Boot0024* USBR BOOT CDROM	PciRoot(0x0)/Pci(0x14,0x0)/USB(11,1)
Boot0025* USBR BOOT Floppy	PciRoot(0x0)/Pci(0x14,0x0)/USB(11,0)
Boot0026* ATA HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0027* ATAPI CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)

I’d appreciate any help to resolve this issue.

That is an interesting problem. It looks like grub-mkconfig never returns and times out.

Probably, we should make that not cause the install to fail.

For now, you can work around it by removing that module as it is non-critical.

Before launching the installer, edit either /etc/calamares/settings_online.conf or /etc/calamares/settings_offline.conf depending on if you want an online or offline install.

Once in the file, comment out the windowsbootentry module.

Then launch the installer and proceed as normal.

I have similar issues while installing, both online or offline.
During bootloader choose screen, I can not change anything, also when I click next, it go next, but when I click install, it switch back to those bootloader choose screen, than nothing happened for 5 min and than it says installation finished.
I rebooted my laptop, but something is weird, looks like it is not installed correctly.

how to fix that ?

That is a different issue.

The fix for that is here:

Thanks, you are fast :slight_smile:
Should I do this : sudo pacman -R xf86-video-intel in installation , before I run Install window or ?

just found it…

Before starting the installer, uninstall xf86-video-intel and restart X11.(Don’t reboot)

1 Like

The specific commands are in the post just after mine in that topic.

Yea, wrote it abow.

I hope it will work, I already downloaded 5 times iso file and repeated installation 6 times…

1 Like

You should now if it worked as soon as you get to the bootloader selection screen. That is where the display issues usually show up.

Thank you so much. It works. now installing normally :slight_smile: gnome and kde .

you are the best :wink:

1 Like

After first reboot, it worked fine in Gnome, but than I switched to KDE and same glitches happened again

Thanks, I commented out the ‘windowsbootentry’ lines and retried install.
This time it got past running grub-mkconfig but it hangs again later and never completes installation. The installer screen says it’s running a script and the log shows what looks like output from fdisk -l. I cancelled the install and posted logs in
What else can I try?

A post was split to a new topic: Install failing due to read-only EFI partition

It seems os-prober can’t run on your system for some reason. That is also why grub-mkconfig is failing.

As a workaround, you can edit /etc/calamares/scripts/ and remove the os-prober line.

Thanks again for the prompt reply, removing the os-prober line allowed installation to complete successfully.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.