Install failing due to read-only EFI partition

Hi. I have the same error.

This is my experience so far:
I have a DELL XPS 15 9520
With windows 11 installed
I shrinked my 2TB NVMe windows to extract 256 GB free space for EndeavourOS (and turned off BitLocker for it)
I had to disable SecureBoot to be able to boot into my bootable USB created with Rufus
I had that bug that it freezes on selecting bootloader screen: Cassini installation bootloader choice issue - #31 by Ardeshir

I had to remove xf86-video-intel and restart lightdm.service

Then I faced this issue: “windowsbootentry”

Then I removed “windowsbootentry” from settings_online.conf

And now it threw another error:

Boost.Python error in job “bootloader”. Details:

<class 'OSError'>
[Errno 30] Read-only file system: '/tmp/calamares-root-uewi826f/efi/1a40278f13ab4d0eb37d102d3483462a'

File "/usr/lib/calamares/modules/bootloader/", line 890, in run

File "/usr/lib/calamares/modules/bootloader/", line 855, in prepare_bootloader

File "/usr/lib/calamares/modules/bootloader/", line 519, in install_systemd_boot

File "/usr/lib/calamares/modules/bootloader/", line 226, in create_systemd_boot_conf
os.makedirs(machine_dir, exist_ok=True)

File "/usr/lib/python3.10/", line 225, in makedirs
mkdir(name, mode)

And this is the whole termbin:

This is the link to my other message in my other topic: Cassini installation bootloader choice issue - #29 by Ardeshir for more information

It looks like you are re-using an EFI partition and it is being mounted read-only. Does it possibly have some filesystem errors that are preventing it from being mounted RW? How much free space do you have in that partition?

Hi. I don’t know the answer to your questions, would you help me know how to find out? I also don’t know what is EFI, is there any setting I need to change in BIOS? I already disabled Secure boot.

I’m using “Replace Partition” option and selecting an entire partition (256GB, all free).
And I’m leaving bootloader to systemd (default option)

Here is the aauto-generated report:

Can you post the output of sudo parted -l

Thanks for your reply.

This is the output of sudo parted -l:

Model: SMI USB DISK (scsi)
Disk /dev/sda: 31.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  31.0GB  31.0GB  primary  fat32        boot, lba

Model: PC801 NVMe SK hynix 2TB (nvme)
Disk /dev/nvme0n1: 2048GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  253MB   252MB   fat32        EFI system partition          boot, esp
 2      253MB   387MB   134MB                Microsoft reserved partition  msftres
 3      387MB   1751GB  1751GB               Basic data partition          msftdata
 4      1751GB  2026GB  275GB   ext4         endeavouros
 5      2026GB  2027GB  1038MB  ntfs                                       hidden, diag
 6      2027GB  2047GB  19.7GB  ntfs                                       hidden, diag
 7      2047GB  2048GB  1551MB  ntfs                                       hidden, diag

This part:

 4      1751GB  2026GB  275GB   ext4         endeavouros

I believe a result of previous error-y installations.

What is /dev/sda?

It looks like Calamares is identifying that as an efi partition. It probably isn’t.

My suggestion would be that when you select “Replace Partition” in the installer, you choose the option to create a new EFI partition in the dropdown below. That will probably resolve your issue.

Thanks I will try that

That /dev/sda seems to be my live bootable 32 GB USB which I have my Endeavouros running from. (I used Rufus to create that)

Hello @dalto
I just tried installing Endeavouros again, this time in the same page I selected “New” EFI partition, which resulted in creating a 1 GB EFI partition + the rest of the partition dedicated to Endeavouros (255 GB)

I confirmed and pressed install. But as soon as the installation progress started, it exited at 1% and the window closed. (probably crashed)

I don’t know what to report here or where to get logs from.

Can you try again and see if the same thing happens?

If it does, the log will be in the home directory of the live user.

Yes I tried again without rebooting the system. But it all went well. Even the problem with windowsbootentry was resolved.

I think I’m safe now. Thank you very much for your help during the process

1 Like