Can't Wake up Endeavour After Sleep

Hello, first post here. After my machine goes to sleep, no matter what settings I use there, it won’t wake back up.
Keyboard is unresponsive and I have to power off and back on again.
I have another distro (Mint Cinnamon) where it does wake back up.
I tried another KDE with MXLinux and had the same problem but I’m liking Endeavour better even though I can’t wake it up.

I’ve seen a few other posts from a search here with a similar issue and hoping there is some kind of fix/resolution.

Kernel: 6.6.33-1-lts arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4802
    date: 06/15/2023
  Info: 16-core AMD Ryzen 9 5950X [MT MCP] speed (MHz): avg: 2275
    min/max: 2200/5083
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti GDDR6X] driver: nouveau
    v: kernel
  Display: wayland server: v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting dri: nouveau
    gpu: nouveau resolution: 2327x1309
  API: EGL v: 1.5 drivers: nouveau,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 24.1.1-arch1.1
    renderer: NV174
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8168
  Local Storage: total: 20.92 TiB used: 1021.71 GiB (4.8%)
  Memory: total: 64 GiB note: est. available: 62.69 GiB used: 4.83 GiB (7.7%)
  Processes: 574 Uptime: 1h 40m Shell: Bash inxi: 3.3.34

1 Like

Follow point 10.


To save and restore all video memory contents, use the NVreg_PreserveVideoMemoryAllocations=1 kernel module parameter for the nvidia kernel module and enable nvidia-suspend.service, nvidia-hibernate.service, and nvidia-resume.service.

See NVIDIA’s documentation for more details.

Thanks for the reply!
I’m not clear on how to set the Nvidia kernel module parameters per the above (exactly what command(s) to use)?

1 Like

edit /etc/kernel/cmdline

cat /etc/kernel/cmdline
 nvme_load=YES quiet NVreg_PreserveVideoMemoryAllocations=1 nvidia_drm.modeset=1 nvidia-drm.fbdev=1 pci=nommconf nowatchdog rw root=UUID=1fe53a1a-6f4f-47df-a8cd-2f3d78155d7c resume=UUID=0942ac91-77f1-46a0-b31e-e10933c7b1bb


sudo reinstall-kernels

edit /etc/default/grub
No example - sorry!

sudo grub-mkconfig -o /boot/grub/grub.cfg 

Enable services:

sudo systemctl enable nvidia-suspend.service


## >> /etc/modprobe.d/nvidia-power-management.conf
options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp


1 Like

Ok Thanks!

This is that line now… GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
What do I edit in it?

add NVreg_PreserveVideoMemoryAllocations=1 space either side.

Haven’t used grub in a while, hence no example :smiley:

Just about there but the terminal is complaining about…
sudo grub-mkconfig -o /boot/grub/grub.cfg … saying cmd not found.

default is systemd-boot not grub… you will only have grub in case you specifically changed that o installer.

Wasn’t able to enable nvidia suspend.service

Failed to enable unit: Unit file nvidia-suspend.service does not exist.

1 Like

This is part of nvidia-utils package., this does not exist you do not have a proper Nvidia driver installation running.

pacman -Qo /usr/lib/systemd/system/nvidia-suspend.service /usr/lib/systemd/system/nvidia-suspend.service is owned by nvidia-utils 550.90.07-2

Also i am sure you do not run grub or you screw the grub setup.
As i said, default selected in installer is systemd-boot.
And your output looks like you where installing grub package later.

To check give this:
cat /etc/fstab | eos-sendlog

It seems they don’t.

1 Like

Well, too late for that as my post above showed, I did run it following the instructions given and now can’t boot the system.

Instructions was given for both bootloaders… and if grub package was not installed the command would not have changed anything …

1 Like

Would not exist if systemd-boot - this is a system using grub.

I guess I’m not understanding that statement. If the command wouldn’t change anything what is preventing the OS from booting now?

Boot off the live media, reverse the edits and reboot, the changes are only to configuration files - can easily be undone.

What edits exactly do I change?

Only you know what you did!

Huh? I followed the instructions you gave me. What is “reversible” in those instructions???

Not really being clear on the state of your system at this point, I would suggest to backup your personal data and reinstall with the defaults defined in the installer.

If you then need help with any configuration post-install, post about it here on the forum.

I wouldn’t follow any instructions from www as they may not meet the specifics of EnOS.