Can't reboot or shutdown

Hi guys,

New to Endeavour and got my system set up apart from one issue;. I can’t seem reboot or shutdown my laptop without it hanging, and I don’t know which logs to search through.

If I switch to tty4 and type reboot, all I get is a blinking underline cursor. I’ve tried adding reboot=pci to my kernel argument in grub but it’s not helping.

This is my manual partitioning setup in case it helps:

Device             Start       End   Sectors  Size Type
/dev/nvme0n1p1      2048    616447    614400  300M EFI System
/dev/nvme0n1p2    616448  63531007  62914560   30G Linux filesystem
/dev/nvme0n1p3  63531008 482961407 419430400  200G Linux filesystem
/dev/nvme0n1p4 482961408 500117503  17156096  8.2G Linux swap

Any ideas?

Thank you

If you’re shutting down from a terminal, try systemctl poweroff or systemctl reboot instead.


Welcome @doron
I’m not sure what era your hardware is but you may need to add a kernel parameter for acpi due to poor implementation in the Bios.

example: acpi_osi=‘windows 2017’

Here is some info

Edit: As @fosskers has said you can use the terminal commands to poweroff or reboot if needed.

Thank you @ricklinux, I just realized you’re the reason I’m still on Endeavour. I was about to nuke it due to not having working sound but found your post about adding sof-firmware and that worked. Could the solution be similar here? I should have mentioned that I’m running a new Dell XPS 13 3910, and that arguments like reboot --force work fine.

Yes a lot of other distros may have these packages included but on Arch some of these things just have to be done as required. sof-firmware is somewhat new. I’m not exactly sure how long it’s been around but it’s called sound open firmware and is used on intel sound. Haven’t run across other hardware that uses it?

Anyway Dell XPS 3910 ya I’m not sure why the hang on shutdown reboot. It can be a number of things. I’m not an expert. I just try to look at hardware and find solutions. Is it freezing on shutdown or hanging?

Edit: Is it XPS 3910 or 9310?

This laptop is like 2019 or 2020 era so i would think you could try acpi_osi=‘Linux’ or Windows 2019? These are things you can try and if they don’t work just revert what you change. Also not sure if TLP is installed automatically or not.

  1. It just hangs with a blinking cursor if I do it in tty. Can’t seem to find a way to do a verbose shutdown or see a log file of where it went wrong (like a reverse dmesg).

Maybe downgrade the kernel?

May of had same problem . Had to hold power button to hard kill . Then when restarted laptop it took over 5 min of black screen with bouncing curser before it booted . I was worried but patience solved my scare . May have been even 10 min as I thought I broke my system . Just that scare but all running smooth now .

ok you’re on to something. I removed TLP and can now pass a successful shutdown command without --force from the terminal or tty1. Issue is, Gnome seems to use a different command and still hangs.

When shutting down, if you wait about 2 minutes, does it eventually shut down?

Perhaps removing the quiet from the grub command line would give a hint about what is going on at shutdown?

Did you try journalctl (or with sudo if it complains about permissions) - arch wiki page.
Look for line -- Reboot --. That should be the last entry before shutdown (or first entry for next bootup?).
That may give you some clues.

I don’t understand why anyone wants to hide that awesome wall of text during boot. It’s just one of the benefits of linux system. I can just see right away that the system is [ OK ] :grinning:


Agree 1,000,000,000%


Coz it’s visual bloat, i’d for example want to see wall of errors if there are some, but if everything is fine…
Why would i need to know? :upside_down_face:

Some bloat is just woth it. :wink:

You don’t. But anyone who wold be looking over your shoulder would definitely think “btw, he must be using arch” and that worth something, no? :rofl:


I mean…I could enable it to gain some over-shoulder h4xXx0r points :joy:
Things is, having someone over your shoulder is bloat, and security risk!! Not my style :rofl:

I’d love to, but it’s on my screen for less than a second so…much sad.

I’ll have to look into journalctl, a quick glance didn’t show anything weird.

Update though, I created a second user and can reboot without issues, I assume that would narrow down the cause?

Thanks all

one can only dream

So you removed tlp and it shutdown okay from the tty with command but you’re saying from Gnome desktop the shutdown still hangs? You created another user account and all is good? Did you remove the original account and use same password and root password? Hope it’s working for you.

I think the one successful reboot was a fluke, still not working in this account but I suppose re-linking /home to a new user would work until it potentially breaks again. Journalctl -b -1 doesn’t show anything either just that shutdown has been started.

I guess the temp solution is to create a new user, link /home, delete old user, and rename as necessary.

Edit: I found this resource to get system logs for shutdowns that hang indefinitely (my case, which is why journalctl doesn’t show anything) but I don’t think I’m up to the task at this point.