Can't perform system update using Yay/Pacman results due to corrupt signature

Hi all.

I’ve sent my computer to repairs under warranty. Today, after a week and a half, I got a new unit, and I tried to update the system and I get multiple error messages of corrupt signatures (same hard drive and memory, but everything else is supposed to have been replaced). It basically appears that each package is corrupt. I tried applying several fixes I’ve found like this:

or this:

https://bbs.archlinux.org/viewtopic.php?id=233480

or even this:

https://archlinuxarm.org/forum/viewtopic.php?f=9&t=14384

But all failed.

Is there a way for me to fix this? Or should I simply install the system again?

Thanks.

ι-μ

Quite frankly having waited this long I would wait a little longer and reinstall.
Do you have a separate Home partition? In that case do not format it and use the same username, and it will just use it (and apply the settings in your .conf files) without you having to do anything else.

I also think the same can be applied if you when booting up the live USB opens your / on your hard drive and just delete everything but the files in your /home folder and then reinstall it without formatting the drive.

Just remember you have to go into gparted and UNMOUNT the drive before installing on it.

1 Like

This! I’ve seen any number of failed installs due to just this one thing.

Hello @yotama9
Have you tried clearing all the cache and then sync before trying to do the update?

sudo pacman -Scc
yes to both
sudo pacman -Syy
sudo pacman -Syu

1 Like

HI i had a similar issue and not sure is related to yours, Refer below link

I know the first thing I would try for this:

$ sudo pacman -S archlinux-keyring

followed by a system update

$ sudo pacman -Syyu

I’m not saying the second ‘y’ is needed, just that I would ensure everything is refreshed at the same time :grin: Should sort out the ‘corrupted’ packages, though.

1 Like

Hay, these are all attempts that I’ve made. I ended up installing the OS again. I now have the issue that I cannot use my bluetooth keyboard.

https://endeavouros.com/?s=enable+blue+tooth

1 Like

Ha, thanks for the help :smiley:, but my issue is not that :sleepy:

I can connect to my keyboard, but there is no response once I’m connected. Also, if I turn off the connection to the keyboard, I have to remove the device and then pair it again in order to be able to connect the keyboard again.

I’ve posted a separate topic about this.

Thanks.