Bluetooth keyboard connected, but cannot type

Hi. I have a bluetooth keybaord logitech k780 which works fine on my Windows machine. I’ve recently replaced the machine, and the keyboard worked fine on it, but I had to format the machine. Now I cannot use the keyboard. I can pair it without a problem, but after I pair it, the machine doesn’t respond to the keyboard. If I try to disconnect and then connect the keyboard, the machine tries for some time and then stops. I tried to look for similar problems but I’ve only found this but this is from 2015 and the monitor he uses to debug offers me an empty output.

I would appreciate your help in solving this.


First of all open a terminal before try to connect, and run live journal to see may error messages:
journalctl -f

Hi, thanks for the tip. I looked at the log and I indeed see this error:

input-hog profile accept failed for <address>

It appears to be related to this bug report. This is bad news for me since I don’t feel like compiling a kernel. Is there a workaround for this?


that bug reports begins like this:

After upgrading from bluez-5.53-1-x86_64 to bluez-5.54-1-x86_64.pkg my “Bluetooth Low Energy” mouse (Model: Rapoo M500)

What about downgrading the package back to that version that worked?
You can use package downgrade to do that.